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About This Manual  

This user manual describes how to operate the P20/P10/Q8 seamless switchers and 
U5/U5 Pro event controllers, as well as how to use the matched all-new event 
management software PixelFlow. This manual is designed to be a reference for your 
daily use of our products. It contains a complete description of the hardware and 
control software. 

 Note  

Always check for the latest version of all documents at www.pixelhue.com.  

Version History  

Version Date Changes 

V 1.0.0 2023-06-30 First release 

Symbols and Pictures  

Symbol Overview 

 Danger Indicates a hazard with a high level of risk, which if not 
avoided, will result in death or serious injury. 

 Warning Indicates a hazard with a medium or low level of risk, which if 
not avoided, could result in minor or moderate injury. 

 Caution Indicates a potentially hazardous situation, which if not 
avoided, could result in equipment damage, data loss, 
performance degradation, or unexpected results. 

 
Note Provides additional information to emphasize or supplement 

important points of the main text. 

Picture Overview 

Images and pictures given in this manual are used for illustration purposes only. The 
actual product may vary due to product enhancement. The content of the images can 
be slightly different from reality, such as device types, installed modules, form and 
position of software windows on the screen. 

http://www.pixelhue.com/
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2 Safety 

Overview 

 General Considerations 
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 Cable Requirements 

 Electrical Safety 

 Unpacking and Inspection 
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 Notes and Cautions 
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General Considerations 

To ensure that you can use this product correctly and safely, please be sure to 
observe the following precautions: 

 Before performing any operation, make sure that you have read all the operating 
instructions provided by the device, especially the instructions that may 
endanger the personal safety and device safety, such as dangers, warnings and 
cautions, to minimize the probability of accidents. 

 All the operations must conform to local safety codes. When the safety and 
precautionary measures described in this manual conflict with local safety 
codes, please follow the local codes. 

 The personnel responsible for installing and maintaining the device must be 
professionals who have been trained and have mastered the correct operation 
methods and all safety precautions. Only trained and qualified personnel can 
perform device installation and maintenance. 

 This device must be used in an environment that meets the design 
specifications; otherwise, it may cause device failure. The resulting device 
function abnormalities or component damage, personal safety accidents, 
property losses and other situations are not included within the scope of the 
device warranty. 

2.1.1 General Safety 

 When operating the device, you must strictly abide by the local laws and 
regulations. The safety precautions described in this manual are only a 
supplement to the local safety laws and regulations. 

 The "Danger", "Warning" and "Caution" items described in this manual are only 
supplementary instructions for all safety precautions. 

 To ensure personal and device safety, please strictly follow all the safety 
precautions on the device labels and described in this manual when installing 
the device. 

2.1.2 Environmental Requirements 

 Ensure adequate air flow in the equipment room. 

 Take necessary measures to prevent dust, water and static electricity. 

 Avoid long-term direct sunlight. 

 Keep the device away from heat and ignition sources. 

 Do not place the device in an explosive atmosphere. 

 Do not place the device in a corrosive environment. 

 Do not place the device in a strong electromagnetic environment. 

2.1.3 Device Safety 

 Before operating, fix the device on the floor or other stable objects, such as a 
wall or mounting bracket. 
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 During transportation and use of the device and its packaging, the device must 
be fixed stably to avoid falling. 

 Do not step on, hit and violently operate the device and its packaging to prevent 
damage to the device or packaging box. 

 Do not block the ventilation openings during operation. 

 Tighten the board or card screws with a tool. 

 After the installation, remove the empty packing materials from the device area. 

 Save the packing box and materials for possible storage and transportation in 
the future. 

 Always wear anti-static wrist bands and insulating gloves when touching the 
static-sensitive components. 

 Avoid dropping any object into the chassis. 

 Keep the device away from conductors that are easy to induce lightning to avoid 
lightning strikes to the device. 

 Do not make the circuit faces of the boards or cards contact each other. 

 Do not touch the circuit, components, connectors or wiring slots of the boards or 
cards with bare hands. 

 Do not repair the device without authorization. Only trained professionals can 
maintain the device. You can contact PIXELHUE at any time if needed. 

 Always use the spare parts recommended by PIXELHUE. 

 Regularly clean the dust on the heat dissipation holes to prevent the dust from 
blocking the holes and thus affect the heat dissipation of the device. 

2.1.4 Personal Safety 

 Place the device in a stable location to prevent personal injury caused by falling. 

 Avoid bare wires and maintain or replace them in time when they are damaged. 

 Do not operate the device and connect cables outdoors under thunderstorms. 

 Do not wear watches, rings, or other metal jewelry when installing spare parts or 
maintaining the device. 

Device Carrying 

 Do not relocate a powered device, and do not take any objects that may cause 
danger to the relocation. 

 Always pay attention to the wheels at the bottom of the flight case during 
transportation to avoid them being jammed by stones or deformed due to 
external forces. 

 Always hold the handles of the flight case firmly when pushing a flight case with 
wheels. Do not stack other devices on the flight case. 

 The relocated device should be repacked in the original factory packaging. 

 When handling or placing the boards or cards, bare board components or 
modules, always package them individually. 
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 When carrying the device with your bare hands, always wear protective gloves to 
avoid injury. 

 When carrying the device, handle it gently and always hold the handles of the 
device or drag the bottom edge of the device. Do not hold the handles of a 
device component. 

 When the device weight exceeds the carrying limit of a single person, carry it 
with multiple people or use a carrying tool. 

 When using a forklift or handcart for transportation, place the device stably to 
ensure the device will not tip over. 

The following table lists the maximum weights that adults can carry at a time 
specified by some organizations for your reference. 

Organization Weight 

CEN (European Committee for Standardization) 25 kg/55.13 lb 

ISO (International Organization for Standardization) 25 kg/55.13 lb 

NIOSH (National Institute for Occupational Safety and Health) 23 kg/50.72 lb 

HSE (Health and Safety Executive) 25 kg/55.13 lb 

General Administration of Quality Supervision, Inspection and 
Quarantine of the People’s Republic of China  

Male: 15 kg/33.08 lb 

Female: 10 kg/22.05 lb 

Device Mounting 

When the device is installed on a desktop or into a rack, the desktop or rack must 
bear at least 4 times the device weight. 

2.3.1 Mounting on a Desktop 

 Ensure the stability and grounding of the desktop or working table. 

 Ensure that the device is placed horizontally and do not turn it over or hang it on 
the wall. 

 Do not place other objects on the device. 

 Do not put water cups, beverages and other containers with liquid close to or on 
the device to avoid liquid leakage and thus cause safety hazards. 

 If any object or liquid accidentally enters the device, stop using the device and 
disconnect the power cord and all cables connected to the device immediately, 
and then contact the after-sales personnel. 

 When handling a flight case with wheels, please lock and fix the wheels to 
prevent the device from sliding. 

 When stacking, ensure all the devices are stacked stably to avoid device damage 
and personal injury caused by falling.  

2.3.2 Mounting into a Rack 

 The rack must be fixed properly to avoid tilting and falling, and thus cause 
personal injury and device damage. 
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 When a device is mounted into a rack, all mounting holes must be fixed with 
screws. 

 Ensure the rack is well ventilated. It is recommended to reserve at least 1U 
space between the stacking devices, and the heat dissipation vents must not be 
obstructed and keep at least 10 cm distance from other objects. 

2.3.3 Grounding 

 Connect the grounding wire first when installing a device, and disconnect the 
grounding wire at last when removing the device. 

 The connecting surface of the grounding wire and the device must have good 
conductivity. Spray painting is strictly prohibited, and there must be sufficient 
fastening force between the connecting parts. 

 Do not operate the device when the grounding conductor is not installed. 

 There must be no joints in the middle of the grounding wire, and it is strictly 
prohibited to install a switch or fuse on the grounding wire. 

 For devices using a three-pin socket, ensure that the ground terminal in the 
three-pin socket is well grounded. 

Cable Requirements 

2.4.1 Power Cords 

 Warning 

Do not install or remove the power cord when the device is powered on. When the 
power cord core contacts the conductor, an electric arc or spark will be generated 
which may result in fire or eye injury.  

 Protect the power cord properly to prevent it from being punctured to avoid 
personal injury or fire caused by a short circuit. 

 To ensure the safety of the device and personnel, be sure to use the matched 
power cord. 

 User-supplied cables must comply with local cable regulations and device cable 
requirements. 

 Before installing or removing the power cord, turn off the device power first. 

 Check the electrical plug regularly and wipe off the dirt or dust accumulated on 
the plug. 

 Before connecting the power cord, read the labels or markings on the power 
cord to make sure it is a matched one. 

The device is intended to operate from an AC power source with a voltage range of 
AC 100–240V~, 50/60Hz. Various standard plugs are shown in the figure below. 

US NEMA5/15 Europe CEE 7 China GB 2099 UK BS 1363 
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E Earth   N Neutral   L Live 

2.4.2 Signal Cables 

 Before using a DVI signal cable, check whether the pins on the cable connector 
are vertical and even. If not, please replace the cable. 

 Before connecting the signal cable to the device, check whether there is any 
object in the device connector. If yes, remove the object first. 

 If the signal cable has not been used for a long time, discharge static electricity 
before using it. 

 Under normal working conditions of the device, it is recommended that non-
technical professionals do not perform hot-swapping to avoid device damage. 

2.4.3 Miscellaneous 

 Signal cables must be bound separately from strong current cables or high 
voltage cables. 

 When the temperature is too low, severe shock and vibration may cause brittle 
cracking of the plastic sheath of the cable. All cables should be laid and installed 
when the temperature is above zero. 

 If the storage temperature of the cable is below zero, the cable must be moved 
to room temperature and stored for more than 24 hours before laying and 
installation. 

 When carrying cables, especially in a low-temperature environment, always 
handle the cable with care. Violent handling, such as pushing down the cables 
directly from a high place, is prohibited. 

Electrical Safety 

2.5.1 Battery 

 The battery is not intended to be replaced. 

 Always follow the relevant instructions to dispose of batteries. 

 Disposal of a battery into fire or a hot oven, or mechanically crushing or cutting 
of a battery can result in an explosion. 

 Leaving a battery in an extremely high temperature surrounding environment can 
result in an explosion or the leakage of flammable liquid or gas. 

 A battery subjected to extremely low air pressure may result in an explosion or 
the leakage of flammable liquid or gas. 
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2.5.2 Electromagnetic Interference 

 Keep the device away from transformers, high-voltage power lines and high-
current devices. 

 Keep the device away from high-power broadcast transmitters. 

 If there is a mobile communication transmitter around the device, its 
interference degree should meet the requirements of relevant standards. If 
needed, take necessary measures to prevent interference, such as shielding and 
isolation. 

 When using hand-held wireless communication devices, such as interphones, 
keep at least 30 cm away from the device. 

2.5.3 Anti-Static 

 Always wear anti-static wrist bands and insulating gloves when touching the 
static-sensitive components. 

 Always hold the board by the edges to avoid touching the circuits or 
components, and do not touch the chip with your hands. 

 The disassembled board must be packaged with anti-static packaging material 
before storage or transportation. 

Unpacking and Inspection 

2.6.1 Unpacking 

 After receiving the device, check whether the packing box is damaged. If there is 
any damage, do not open the box and contact the carrier in time to confirm the 
damage to the device and matters related to compensation. 

 After unpacking, save the packing box and materials for possible storage and 
transportation in the future. 

2.6.2 Inspection 

 When the packing box is in perfect condition, unpack the box. Check the 
appearance of the device for damage. If there is damage, please contact the 
salesperson. 

 Check the box contents according to the packing list described in the certificate 
of approval. If any item is missing, please contact the salesperson in time. 

Device Labels 

Labels Description 

 

Warranty void if removed 

Do not open the chassis. If this label is damaged, the device 
will not be covered by the warranty. 
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Labels Description 

  

 

Grounding 

The two ends of the grounding wire are connected to the 
device and the grounding point respectively, which means 
that the device must be grounded through the grounding 
point to ensure the normal operation of the device and the 
personal safety of the operators. 

 

Sensitive electronic device 

Keep the device away from areas with strong 
electromagnetic radiation to avoid electromagnetic 
interference and thus affect the image output quality. 

 

Device carrying 

The device needs to be carried by multiple people. 

 

Removing cards 

Remove cards before taking out the motherboard. 

Notes and Cautions 

2.8.1 Installation Notes 

When the product needs to be installed on the rack, 4 screws (M5*12) should be 
used to fix P20/P10 and 16 screws (M5*12) should be used to fix Q8. The rack for 
installation shall bear at least four times the total weight of the mounted equipment. 

a) Elevated Operating Ambient - If installed in a closed or multi-unit rack assembly, 
the operating ambient temperature of the rack environment may be greater than 
room ambient. Therefore, consideration should be given to installing the 
equipment in an environment compatible with the maximum ambient 
temperature (Tma) specified by the manufacturer. 

b) Reduced Air Flow - Installation of the equipment in a rack should be such that 
the amount of air flow required for safe operation of the equipment is not 
compromised. 

c) Mechanical Loading - Mounting of the equipment in the rack should be such that 
a hazardous condition is not achieved due to uneven mechanical loading. 

d) Circuit Overloading - Consideration should be given to the connection of the 
equipment to the supply circuit and the effect that overloading of the circuits 
might have on overcurrent protection and supply wiring. Appropriate 
consideration of equipment nameplate ratings should be used when addressing 
this concern. 

e) Reliable Earthing - Reliable earthing of rack-mounted equipment should be 
maintained. Particular attention should be given to supply connections other 
than direct connections to the branch circuit (e.g. use of power strips). 
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2.8.2 FCC Caution 

Any changes or modifications not expressly approved by the party responsible for 
compliance could void the user's authority to operate the equipment.  

This device complies with part 15 of the FCC Rules. Operation is subject to the 
following two conditions: (1) This device may not cause harmful interference, and (2) 
this device must accept any interference received, including interference that may 
cause undesired operation. 

Note: This equipment has been tested and found to comply with the limits for a Class 
A digital device, pursuant to part 15 of the FCC Rules. These limits are designed to 
provide reasonable protection against harmful interference when the equipment is 
operated in a commercial environment. This equipment generates, uses, and can 
radiate radio frequency energy and, if not installed and used in accordance with the 
instruction manual, may cause harmful interference to radio communications. 
Operation of this equipment in a residential area is likely to cause harmful 
interference in which case the user will be required to correct the interference at his 
own expense. 

2.8.3 Others 

 This is Class A product. In a domestic environment, this product may cause 
radio interference in which case the user may be required to take adequate 
measures. 

 This product can only be placed horizontally. Do not mount vertically or upside-
down. 

 Please read the specifications thoroughly and use the product in accordance 
with the requirements. If you have any questions about the specifications, please 
contact us immediately. If you use the product improperly, not following the 
requirements, or for illegal purposes, you shall be solely responsible for any 
consequences arising therefrom. 

 If the product does not have the relevant certifications required by the countries 
or regions where it is to be sold, please contact PIXELHUE to confirm or address 
the problem. Otherwise, the customer shall be responsible for the legal risks 
caused or PIXELHUE has the right to claim compensation. 
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3 Terms and Definitions 

PVW PVW is an abbreviation for Preview. The PVW area displays the pre-
editing content before it is sent to PGM. 

PGM PGM is an abbreviation for Program. The PGM area displays the real-
time output image. 

Take Take is an action of sending the PVW content to PGM with a transition 
effect. 

Cut Cut is an action of sending the PVW content to PGM directly, without 
any transition effect. 

FTB FTB (Fade to Black) is an action of making the screen fade to black. 

T-Bar T-bar is a lever that manually controls the progress of sending PVW to 
PGM. 

LOGO LOGO is a special layer with the highest priority and is displayed in 
front of all other layers. LOGO consumes no processing resources and 
displays an unscaled image on the screen. 

BKG BKG is an abbreviation for background. BKG is a special layer that has 
the lowest priority and is displayed beneath all other layers. BKG 
consumes no processing resources and fills the whole screen. 

MVR MVR is an abbreviation for Multiviewer. An MVR connector is used to 
connect a confidence monitor for displaying the specific input or 
output content, such as the presenter's laptop. 

AUX AUX is an abbreviation for auxiliary. An AUX connector is used to 
output the input source, PVW or PGM, to a specified monitor, such as 
a teleprompter. 

AOI AOI is an acronym for Area of Interesting. AOI allows users to view a 
specific output area they are interested in. 

Aspect Ratio Aspect ratio is the ratio of a layer/image width to its height. It is 
commonly expressed as two numbers separated by a colon, as in 16:9. 

Contrast  Contrast defines the difference between the darkest and brightest 
areas of an image displayed on the screen. The greater this value is, 
the bigger this difference will be. 

Gamma Gamma defines the degree of distortion of the image color. The 
greater this value is, the more distorted the color will be. 
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Hue Hue defines the gradation or variety of the image color. The greater 
this value is, the more intense the color will be. 

Saturation Saturation defines the purity or vividness of the image color. The 
greater this value is, the purer the color will be. 

Color Space Color space is a mathematical model that maps the colors that can be 
reproduced by a device to a standard color model, usually the RGB 
model. 

Bit Depth Bit depth refers to the color information stored in an image. The higher 
the bit depth of an image, the more colors it can store. 

Frame Rate Frame rate (expressed in frames per second, or FPS) is the frequency 
(rate) at which consecutive images called frames to appear on a 
display. Frame rate may also be called the frame frequency, and be 
expressed in hertz. 

DSK DSK (Downstream Keying) is an effect allowing one video signal to be 
keyed on top of another video signal. The lightest portions of the DSK 
signal replace the source video leaving the dark areas showing the 
original video image. 

Luma Key Luma key refers to a process to composite a foreground clip over a 
background clip based on the luma levels in a video or image. This is 
most often useful for still images, such as a picture of a logo over a 
black background. 

Chroma Key Chroma key refers to a process that a specific color is removed from 
an image, allowing that portion of the image to be replaced. This color 
can be any solid color, most commonly blue or green. 

HDCP HDCP stands for High-Bandwidth Digital Content Protection, a copy 
protection scheme to eliminate the possibility of intercepting digital 
data midstream between the source and the display. HDCP 1.4 is 
designed for full HD content, while HDCP 2.2 relates to ultra HD 4K 
media. 
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4 Overview  

About This Chapter 

This chapter is designed to introduce you to PIXELHUE event presentation switching 
solution. 

Overview 

 Solution Overview 

 Control Overview 

 Initial Inspection
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Solution Overview 

The event presentation switching solutions include two parts basically: event 
presentation switchers and event controllers/PixelFlow (PC). The solutions are 
specifically designed for easy management of multi-display for small/medium/large-
sized events or visual management systems. 

P20+U5/U5 Pro+PixelFlow 

The P20 can work with the U5 or U5 Pro event controller. The following takes the U5 
as an example for illustration. 

 Switcher mode (P20+U5+PixelFlow) 

In switcher mode, two output connectors work as primary and the other six work as 
backup. The output capacity is up to 8K×2K@60Hz.  

 

 PGM only mode (P20+U5+PixelFlow) 

In PGM only mode, four output connectors work as primary and the other four work 
as backup. The output capacity is up to 8K×4K@60Hz. 
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P10+U5/U5 Pro+PixelFlow 

The P10 can work with the U5 or U5 Pro event controller. The following takes the U5 
as an example for illustration. 

 Switcher mode (P10+U5+PixelFlow) 

The following uses 4K output as an example. One output connector works as primary 
and the other works as backup.  

 

 PGM only mode (P10+U5+PixelFlow) 

The following uses 4K output as an example. Two output connectors work as 
primary. The output capacity is up to 8K×2K@60Hz. The U5 is used as an example. 
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Q8+U5/U5 Pro+PixelFlow 

 Q8+U5/U5 Pro+PixelFlow 

 

P20/P10 

The P20 and P10 are PIXELHUE's all-new 4K presentation switchers fully featured in 
a compact form factor. Featuring high-quality 4K processing, the P series switchers 
are designed with a wide variety of 4K connectors, including HDMI 2.0, DP 1.2, and 
12G-SDI.The P20 and P10 can work in switcher mode or PGM only mode. In switcher 
mode, a single P20 supports up to two 4K×2K@60Hz outputs and a single P10 
supports one 4K×2K@60Hz output. In PGM only mode, the output resolution per P20 
is up to 8K×4K@60Hz and P10 is up to 8K×2K@60Hz. Additionally, the P20 and P10 
come with dedicated AUX outputs connecting to auxiliary devices such as 
teleprompters, and a dedicated Multiviewer output is provided for live monitoring of 
all the inputs and outputs from one display. High-performance image deinterlacing is 
supported. 

Q8 

The Q8 presentation switcher offers incredible real-time 4K video processing power. 
It comes with at most 72x 4K input connectors and 48x 4K output connectors, 
supporting up to 48x 4K concurrent inputs and 16x 4K concurrent outputs. A 
maximum of 32x 4K mixing layers (true seamless transitions) in switcher mode or 
doubled layers in PGM only mode are supported. Additionally, multiple different 
connectors (DP 1.2+HDMI 2.0+12G-SDI) are designed on each input or output card 
and the Q8 has the 8K video processing capability, allowing you to design and 
manage all live events easily and economically. Thanks to the VPU architecture, more 
layers can be added on an output card and you will never worry about not enough 
layers. 

Event Controller U5/U5 Pro 

The U5 is a brand new compact-sized event controller and the U5 Pro is a flagship, 
large-scale event controller developed by PIXELHUE. Compared to their 
predecessors, they feature more innovative design highlights and more convenient, 
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powerful and friendly operation and control over multiple different devices in the 
field, which will further facilitate your events today, such as corporate conferences, 
interactive live events or shows, music tours, immersive art exhibitions, and more. 

Control Overview 

The P20, P10 and Q8 are exceptionally easy to operate. Various control options are 
supported: 

 Front panel buttons and a 5-inch graphical LCD (P20/P10) 

 Event management software PixelFlow (P20/P10/Q8) 

 Event controller U5/U5 Pro (P20/P10/Q8) 

Front Panel 

The front panels of the P20 and P10 come with a 5-inch graphical LCD, a knob and a 
variety of function buttons that allow for menu operations by pressing buttons. A USB 
port is provided on the front panel for updating device firmware, import and export 
files. For more information about the P20 and P10 front panels, please refer to 5 
Hardware Introduction. 

PixelFlow 

The event management software PixelFlow allows you to manage and control the 
presentation switchers uniformly. The software consists of several menus and tabs 
that allow you to configure the devices, inputs, outputs, screens and layers, as well as 
manage the presets and Multiviewer. 

Event Controller U5/U5 Pro 

With the design concept of increasing operational efficiency and satisfying the 
various changing needs that may arise from event scenarios, the U5/U5 Pro event 
controllers come with all the crucial functionalities that you may need. Convenient 
control over multiple presentation switchers and media servers greatly simplifies 
your on-site deployment and brings more convenience and ease to your events. 

Initial Inspection  

General 

Before shipment, the devices were inspected and found to be free of mechanical and 
electrical defects. As soon as the devices are unpacked, inspect for any damage that 
may have occurred in transit, and make sure there are no broken parts and the unit is 
free of dents. Save all packing material until the inspection is completed. If any 
damage is found, please contact PIXELHUE or your local distributor immediately. 

After unpacking, please always place the device on a stable, flat and insulated 
support for handling or using. 
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Unpacking 

After the unpacking, it is recommended you check carefully to see whether all 
accessories are included according to the provided packing list. 
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5 Hardware Introduction 

About This Chapter 

This chapter is designed to introduce you to the hardware configuration of the event 
presentation switchers in detail. 

Overview 

 P20 Hardware Introduction 

− Front Panel 

− Rear Panel 

 P10 Hardware Introduction 

− Front Panel 

− Rear Panel 

 Q8 Hardware Introduction 

− Front Panel 

− Rear Panel 

 Note:  

All product pictures shown in this chapter are for illustration purposes only. Actual 
product may vary.  
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P20 Hardware Introduction 

5.1.1 Front Panel 

The P20 front panel is designed with a 5-inch graphical LCD, a knob and a variety of 
function buttons that allow for menu operations by pressing buttons. A USB port is 
provided on the front panel for updating device firmware, import and export files. 

 P20 front panel 

 

1. Chassis handles (L+R) 5. LCD screen 

2. Power button 6. Knob 

3. USB port 7. BACK button 

4. Source buttons 8. Layer and function buttons 

Chassis Handles 

Two handles are provided for easy installation and transportation. 

Power Button 

Press the button to turn on/off the device. To turn off the device, press the button 
and select OK from the dialog box displayed on the LCD screen to confirm your 
operation. 

 Breathing dim white: The power supply is connected. 

 Bright white: The device is turned on. 

USB Port 

A Type-A USB 2.0 port is provided for updating device firmware, import and export 
project files, EDID files, BKG files, LOGO files and logs via USB drive. 

Source Buttons 

Press a button to access the input settings menu or select the source for a layer. 
These buttons can also be used to enter numbers. 
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Button LED color and source status (INPUT 1 to 14): 

 Dim white: No signal and not in use 

 Blinking blue: No signal and in use 

 Breathing blue: Signal accessed and not in use 

 Blue: Signal accessed and in use 

AUDIO: The audio function is currently not implemented. 

LCD Screen 

A 5-inch graphical LCD screen is designed for displaying all the menus, submenus 
and messages of the P20. 

After startup, the screen displays the home screen. For detailed information on the 
home screen, refer to 6.1 P20/P10 Menu Operations. 

Knob 

Rotate the knob to scroll up or down through the menus. 

 Rotate the knob clockwise to scroll down. 

 Rotate the knob counter-clockwise to scroll up. 

Press the knob to select menu items. 

Press and hold the knob and BACK button simultaneously for 3s or longer to lock or 
unlock the front panel buttons. 

Back Button 

Press the BACK button to exit a menu without making changes, to cancel an 
operation, or to return to the home screen. Each press takes you back up the menu 
tree one level. 

Press and hold the knob and BACK button simultaneously for 3s or longer to lock or 
unlock the front panel buttons. 

Layer and function buttons 

 LAYER 1 to 7: Press a button to open a layer and access the layers settings 
menu. Press and hold the button to close the layer. 

− Dim white: The layer is closed. 

− Bright blue: The layer is open. 

− Blue: The layer is in edit mode. 

 PRESET: Press the button to access the preset settings menu. 

− Dim white: The preset settings menu is not displayed. 

− Blinking blue: The preset settings menu is displayed. 

 SCALE: Press the button to enable or disable the full screen scaling of the layer 
at the back of the Z-order. 

− Dim white: Full screen scaling is disabled. 

− Blue: Full screen scaling is enabled. 
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 BKG: Press the button to turn on/off BKG. 

− Dim white: BKG is disabled. 

− Blue: BKG is enabled. 

 FN: This is a custom shortcut button and users can assign a function to the FN 
button. 

When Freeze, FTB (Fade to Black), or Genlock synchronization is assigned, press 
the button to enable the assigned function: 

− Dim white: The function is disabled. 

− Blue: The function is enabled. 

When test pattern or capture is assigned, press the button to access the Test 
Pattern or Capture screen. 

 TAKE: Press the button to switch content from PVW to PGM with a specified 
transition effect. 

− Dim white: Content is not switched. 

− Blinking blue: Content is being switched. 

5.1.2 Rear Panel 

The P20 rear panel provides a variety of 4K I/O connectors including 12x 4K inputs 
(HDMI 2.0, DP1.2, 12G-SDI), 4x HDMI 2.0 outputs, and 8x 10G optical fiber ports. 

 P20 rear panel 

 

1. P_4K_12G SDI Audio-OPT Combo Card 6. Control connectors 

2. Input connectors 1 to 8  7. Power connector and switch 

3. Output connectors 1 to 4 8. LED work lights 

4. Multiviewer output 9. LED work light switches 

5. AUX outputs  

P_4K_12G SDI Audio-OPT Combo Card 

The P20 is designed with a P_4K_12G SDI Audio-OPT Combo Card which offers the 
following input and output connectors. 

 4x 12G-SDI IN & LOOP (INPUT 9 to 12) 
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 4x optical fiber output ports (OPT) 

 4x 3.5 mm audio jacks (AUDIO) including 2x line in & 2x line out (The audio 
function is currently not implemented.) 

Input Connectors 1 to 8 

Each includes a DP 1.2/HDMI 2.0. When two connectors have signals, only one can 
be used as the input source at the same time. 

Output Connectors 1 to 4 

Each includes two HDMI 2.0: 

In PGM only mode, connectors 1, 3, 5 and 7 work as primary and connectors 2, 4, 6 
and 8 copy connectors 1, 3, 5 and 7, respectively. 

In switcher mode, connectors 1 and 3 work as primary. Connectors 2, 5 and 6 copy 
connector 1 and connectors 4, 7 and 8 copy connector 3, respectively. 

Multiviewer output 

The P20 is designed with an HDMI 1.3 for Multiviewer output. A Multiviewer display 
can be connected, allowing for live monitoring of all the inputs and outputs from one 
display. The output resolution is fixed at 1920×1080@60Hz. 

AUX Outputs 

The P20 comes with four HDMI 1.3 for AUX outputs. Auxiliary devices such as 
teleprompters can be connected. The output resolution is fixed at 1920×1080@60Hz. 

Ethernet Ports 

 Two Ethernet ports are provided for control and live input view.  

 One works as primary and the other as backup.  

 They have the same function and share the same IP address.  

Genlock IN & LOOP 

Genlock synchronization signal connectors are provided. 

 GENLOCK IN: Synchronization signal input 

 GENLOCK LOOP: Synchronization signal loop output 

Power Connector and Switch 

 Power connector and rocker switch 

 100-240V~, 3.0-1.5A, 50/60Hz 

LED Work Lights and Switches 

At some event venues, the lights may be very dim. For users’ convenience, the 
P20 is designed with two LED work lights to provide adequate light for rear panel 
operations. The LED work lights come with pushbutton switches (red) next to 
them. 
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Specifications of input and output video connections 

 DP 1.2 

− Maximum resolution: 4096×2160@60Hz/8192×1080@60Hz 

− Minimum resolution: 800×600@60Hz 

− Maximum width: 8192 pixels (8192×1080@60Hz) 

− Maximum height: 8192 pixels (1080×8192@60Hz) 

− Maximum frame rate: 120 Hz 

− EDID management (support for standard resolutions and custom 
resolutions) 

− HDCP 1.3 compliant 

 HDMI 2.0 

− Maximum resolution: 4096×2160@60Hz/8192×1080@60Hz 

− Minimum resolution: 800×600@60Hz 

− Maximum width: 8192 pixels (8192×1080@60Hz) 

− Maximum height: 8192 pixels (1080×8192@60Hz) 

− Maximum frame rate: 120 Hz 

− Support for HDR  

− EDID management (support for standard resolutions and custom 
resolutions) 

− HDCP 2.2 compliant and downward compatible 

 12G-SDI 

− Support for ST-2082 (12G), ST-2081 (6G), ST-424 (3G), ST-292 (HD) 

− Maximum resolution: 4096×2160@60Hz 

− Maximum frame rate: 60 Hz 

− Support for interlaced input signal 

P10 Hardware Introduction 

5.2.1 Front Panel 

The P10 front panel is designed with a 5-inch LCD, a knob and a variety of function 
buttons that allow for menu operations by pressing buttons. A USB port is provided 
on the front panel for updating device firmware, import and export files.  
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 P10 front panel 

 

1. Chassis handles (L+R) 6. LCD screen 

2. Power button 7. Knob 

3. USB port 8. BACK button 

4. Source buttons 9. Function buttons 

5. Layer buttons  

Chassis Handles 

Two handles are provided for easy installation and transportation. 

Power Button 

Press the button to turn on/off the device. To turn off the device, press the button 
and select OK from the dialog box displayed on the LCD screen to confirm your 
operation.  

 Breathing dim white: The power supply is connected. 

 Bright white: The device is turned on. 

USB Port 

A Type-A USB 2.0 port is provided for updating device firmware, import and export 
project files, EDID files, BKG files, LOGO files and logs via USB drive. 

Source Buttons 

Press a button to access the input settings menu or select the source for a layer. 
These buttons can also be used to enter numbers. 

Button LED color and source status (INPUT 1 to 6): 

 Dim white: No signal and not in use 

 Blinking blue: No signal and in use 

 Breathing blue: Signal accessed and not in use 

 Blue: Signal accessed and in use 
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Layer Buttons 

Press a button to open a layer and access the layer settings menu. Press and hold 
the button to close the layer. These buttons can also be used to enter numbers and 
page up and down. 

 Dim white: The layer is closed. 

 Bright blue: The layer is open. 

 Blinking blue: The layer is in edit mode. 

LCD Screen 

A 5-inch LCD screen is designed for displaying all the menus, submenus and 
messages of the P10. 

After startup, the screen displays the home screen. For detailed information on the 
home screen, see 6.1 P20/P10 Menu Operations. 

Knob 

Rotate the knob to scroll up or down through the menus. 

 Rotate the knob clockwise to scroll down. 

 Rotate the knob counter-clockwise to scroll up. 

Press the knob to select menu items. 

Press and hold the knob and BACK button simultaneously for 3s or longer to lock or 
unlock the front panel buttons.  

Back Button 

Press the BACK button to exit a menu without making changes, to cancel an 
operation, or to return to the home screen. Each press takes you back up the menu 
tree one level. 

Press and hold the knob and BACK button simultaneously for 3s or longer to lock or 
unlock the front panel buttons. 

Function buttons 

 PRESET: Press the button to access the preset settings menu. 

− Dim white: The preset settings menu is not displayed. 

− Blinking blue: The preset settings menu is displayed. 

 SCALE: Press the button to enable or disable the full screen scaling of the layer 
at the back of the Z-order. 

− Dim white: Full screen scaling is disabled. 

− Blue: Full screen scaling is enabled. 

 FN: This is a custom shortcut button and users can assign a function to the FN 
button. 

When Freeze, FTB (Fade to Black), or Genlock synchronization is assigned, press 
the button to enable the assigned function: 

− Dim white: The function is disabled. 
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− Blue: The function is enabled. 

When test pattern or capture is assigned, press the button to access the Test 
Pattern or Capture screen. 

 TAKE: Press the button to switch content from PVW to PGM with a specified 
transition effect. 

− Dim white: Content is not switched. 

− Blinking blue: Content is being switched. 

5.2.2 Rear Panel 

The P10 rear panel provides a variety of I/O connectors including 6x 4K inputs (4x 
DP1.2/HDMI 2.0 and 2x 12G-SDI), 8x outputs (2x HDMI 2.0 and 6x HDMI 1.3), and 4x 
10G optical fiber ports. 

 P10 rear panel 

 

1. Input connectors 5 and 6 6. AUX outputs 

2. Input connectors 1 to 4 7. Output connectors 1 to 8 

3. OPT output connectors 1 to 4 8. Control connectors 

4. Audio jacks 9. Power connector and switch 

5. Multiviewer output  

Input Connectors 5 and 6 

Two 12G-SDI IN & LOOP connectors are provided. 

Input Connectors 1 to 4 

Each includes a DP 1.2 and HDMI 2.0. When both have signals, only one can be used 
as the input source at the same time. 

OPT Output Connectors 1 to 4 

Four optical fiber ports are provided for copying the output of two HDMI 2.0 
connectors. 

 OPT 1 and 2 copy the output of HDMI connector 1. 
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 OPT 3 and 4 copy the output of HDMI connector 5. 

Audio Jacks (The audio function is currently not implemented.) 

Four 3.5 mm dual-channel audio jacks are provided, including two line in jacks and 
two line out jacks. 

Multiviewer Output 

The P10 is designed with an HDMI 1.3 for Multiviewer output. A Multiviewer display 
can be connected, allowing for live monitoring of all the inputs and outputs from one 
display. The output resolution is fixed at 1920×1080@60Hz. 

AUX Outputs 

The P10 comes with two HDMI 1.3 connectors for AUX outputs. Auxiliary devices 
such as teleprompters can be connected. The output resolution is fixed at 
1920×1080@60Hz. 

Output Connectors 1 to 8 

The P10 provides eight HDMI outputs including two HDMI 2.0 and six HDMI 1.3. 

SL: 

 In switcher mode, connectors 1 to 4 work as primary connectors for 2K output 
and connectors 5 to 8 copy connectors 1 to 4, respectively. 

 In PGM only mode, eight connectors can work as primary connectors for 2K 
output. 

4K: 

 In switcher mode, connector 1 works as primary connector for 4K output and 
connector 5 copy copies connector 1.  

 In PGM only mode, connectors 1 and 5 can work as primary connectors for 4K 
output. 

Control Connectors 

The P10 provides two Ethernet ports and a Genlock connector with loop-through. 

Ethernet 

Two Ethernet ports are used for control and live input view (One works as primary 
and the other as backup. They share the same IP address.). 

Genlock IN & LOOP 

Genlock synchronization signal connectors are provided. 

 GENLOCK IN: Synchronization signal input 

 GENLOCK LOOP: Synchronization signal loop output 

Power Connector and Switch 

 Power connector: 100-240V~, 3.0-1.5A, 50/60Hz 
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 Power switch: 

− ON: Power on 

− OFF: Power off 

 

Specifications of input and output video connections 

 DP 1.2 

− Maximum resolution: 4096×2160@60Hz/8192×1080@60Hz 

− Minimum resolution: 800×600@60Hz 

− Maximum width: 8192 pixels (8192×1080@60Hz) 

− Maximum height: 8192 pixels (1080×8192@60Hz) 

− Maximum frame rate: 120 Hz 

− EDID management (support for standard resolutions and custom 
resolutions) 

− HDCP 1.3 compliant 

 HDMI 2.0 

− Maximum resolution: 4096×2160@60Hz/8192×1080@60Hz 

− Minimum resolution: 800×600@60Hz 

− Maximum width: 8192 pixels (8192×1080@60Hz) 

− Maximum height: 8192 pixels (1080×8192@60Hz) 

− Maximum frame rate: 120 Hz 

− EDID management (support for standard resolutions and custom 
resolutions) 

− HDCP 2.2 compliant and downward compatible 

 12G-SDI 

− Support for ST-2082 (12G), ST-2081 (6G), ST-424 (3G), ST-292 (HD) 

− Maximum resolution: 4096×2160@60Hz 

− Maximum frame rate: 60 Hz 

− Support for interlaced input signal 

 HDMI 1.3 

− Maximum resolution: 1920×1080@60Hz/2048×1080@60Hz 

− Minimum resolution: 800×600@60Hz 

− Maximum width: 2048 pixels (2048×1080@60Hz) 

− Maximum height: 2048 pixels (1080×2048@60Hz) 

− Maximum frame rate: 120 Hz 

− EDID management (support for standard resolutions up to 
2048×1152@60Hz and custom resolutions) 

− HDCP 1.4 compliant and downward compatible 



Event Presentation Switching Solution User Manual 5 Hardware Introduction 

 

www.pixelhue.com 30 
 

Q8 Hardware Introduction 

5.3.1 Front Panel 

The Q8 front panel is designed with a 7-inch touchscreen, a power button, and two 
LED strips. A LINK port is provided on the front panel to link a second Q8. 

 Q8 front panel 

 

No. Type Description 

1 Power button Power on: Press the button to power on the device. 

Power off: Press the button, and a shutdown prompt 
window appears on the LCD screen. Click or tap Yes to 
shut down the device. 

2 LED strip Indicate the device running status. 

3 Touchscreen Display the device status, menus, submenus and 
messages for parameter settings. 

4 LINK port A reserved port to cascade a second Q8. 

5.3.2 Rear Panel 

The Q8 rear panel provides a variety of I/O connectors including 72x 4K input 
connectors (HDMI 2.0, DP1.2, 12G-SDI), 48x output connectors (HDMI 2.0, DP1.2, 
12G-SDI, 10G OPT). 
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 Q8 rear panel 

 

 Note 

The picture above is the rear panel of the device when it is fully loaded. Users can 
configure input and output cards as needed. 

The input and output cards can be replaced. Refer to the table below for input and 
output card selection.  

 

Card Slot Area Configurable Input and Output Cards 

Input card slot Up to 6 input cards can be installed, which can be selected from the 
following. 

Q_4x HDMI2.0+4x DP1.2+4x 12G-SDI Input Card 

Output card slot Up to 4 output cards can be installed. 

Q_4x HDMI 2.0+4x 12G-SDI Optical Output Card 

Control card Control Card 

Power 
connector 

Support 2 primary and 1 backup power supplies. Before powering on 
the device, connect at least two power supplies. 

Power specifications: 100-240V~, 50/60Hz, 10A-5A 
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Input card 

5.3.2.1.1 Q_4x HDMI2.0+4x DP1.2+4x 12G-SDI Input Card 

 

Connectors 

 4x HDMI 2.0 

 4x DP1.2 

 4x 12G-SDI 

Specifications 

 8x 4K×2K@60Hz concurrent inputs per input card 

 HDMI 2.0 

− Up to 4K×2K@60Hz 10bit 4:4:4, or 4K×2K@60Hz 8bit 4:4:4 

− Support for processing of 8-bit, 10-bit and 12-bit inputs 

− Support for 4:2:0, 4:2:2 and 4:4:4 inputs 

− Support for processing of Full and Limited range videos 

− Support for HDR video inputs 

− HDCP 1.4 and HDCP 2.2 compliant 

− Support for deinterlacing processing 

− Custom resolutions 

Maximum width: 8192 pixels; maximum height: 8192 pixels 

 DP 1.2 

− Up to 4K×2K@60Hz 10bit 4:2:2, or 4K×2K@60Hz 8bit 4:4:4 

− Support for processing of 8-bit, 10-bit and 12-bit inputs 

− Support for 4:2:2 and 4:4:4 inputs 

− Support for processing of Full and Limited range videos 

− Support for HDR video inputs 

− HDCP 1.3 and HDCP 2.2 compliant 

− Custom resolutions 

Maximum width: 8192 pixels; maximum height: 8192 pixels 

 12G-SDI 

− Support for ST-2082 (12G), ST-2081 (6G), ST-424 (3G), ST-292 (HD) and ST-
259 (SD) standard video inputs 

− Compatible with SD-SDI, HD-SDI, 3G-SDI and 6G-SDI 

− Support for interlaced signal inputs 

− No support for EDID management or bit depth settings 
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Status LEDs 

Each input connector has a status LED which indicates source access status. 

 On: The source is accessed. 

 Off: The source is not accessed or it is abnormal. 

Output Card 

5.3.2.2.1 Q_4x HDMI 2.0+4x 12G-SDI Optical Output Card 

 

Connectors 

 4x HDMI 2.0 

 4x 12G-SDI 

 8x 10G OPT 

Specifications 

 The 4x HDMI 2.0 and 4x 12G-SDI connectors are divided into 4 groups. Each 
group includes 1x HDMI 2.0 and 1x 12G-SDI connectors. In each group, only 1 
connector can be used for output each time. 

− Connector 1 (HDMI 2.0) and connector 5 (12G-SDI) are in a group. 

− Connector 2 (HDMI 2.0) and connector 6 (12G-SDI) are in a group. 

− Connector 3 (HDMI 2.0) and connector 7 (12G-SDI) are in a group. 

− Connector 4 (HDMI 2.0) and connector 8 (12G-SDI) are in a group. 

 4x HDMI 2.0 

− Up to 4K×2K@60Hz 8bit 4:4:4 output 

− Support for 8-bit and10-bit output settings 

− Support for 4:2:2 and 4:4:4 output settings 

− Support for YCbCr and RGB color space settings 

− No support for interlaced signal outputs 

− Custom resolutions 

Maximum width: 8192 pixels; maximum height: 8192 pixels 

 4x 12G-SDI 

− Compatible with SD-SDI, HD-SDI, 3G-SDI and 6G-SDI 

− Support for interlaced signal outputs 

 8x 10G OPT 

− Support for single-mode and multi-mode optical outputs, transmission 
distance up to 10km in single mode 

− OPT ports copy outputs on video connectors 
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− OPT 1 and OPT 2 copy the output on connector 1 or 5. 

− OPT 3 and OPT 4 copy the output on connector 2 or 6. 

− OPT 5 and OPT 6 copy the output on connector 3 or 7. 

− OPT 7 and OPT 8 copy the output on connector 4 or 8. 

Status LEDs 

Each HDMI output connect has a status LED which indicates the connection status of 
backend device. The 12G-SDI and optical port do not have status LEDs. 

 On: The output connection is normal. 

 Off: The output connection is abnormal. 

Control Card 

 

ETHERNET 

2x Neutrik Gigabit Ethernet ports 

 The two Ethernet ports work as a copy channel for each other 

 Connect to the U5, U5 Pro or control computer 

 Transmit the input view information to the control computer or U5/U5 Pro event 
controller 

 Support control by central control command 

Multiviewer (MVR) 

2x HDMI 2.0 

Connect to the monitor to display the Multiviewer image in copy or independent 
mode 

 In independent mode, the two Multiviewer connectors are used to display two 
different MVR images 

 In copy mode, HDMI 2 copies the output on HDMI 1 

USB 3.0 

1x USB 3.0 

 Export device logs 

 Update the device and fix system bugs 
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AUDIO 

1x 3.5mm audio input, 1x 3.5mm audio output 

 IN for external audio input connection 

 OUT for audio output 

Dante 

2x RJ45 digital network audio ports for audio input and output 

 Support network audio input and output 

 Support 64x64 audio swapping 

GENLOCK 

1x GENLOCK IN, 1x GENLOCK LOOP 

 Support Bi-Level and Tri-Level 

 GENLOCK IN: Accept the external sync signal 

 GENLOCK LOOP: Loop the sync signal 
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6 Menu Operations  

About This Chapter 

This chapter introduces you to the system menus of the P20/P10 and Q8, including 
how the menus are accessed and the available functions and parameters. The menu 
pictures are presented throughout the chapter. 

Overview 

 P20/P10 Menu Operations 

− Startup and Shutdown 

− Home Screen 

− Input 

− Output  

− Layer 

− Display 

− Multiviewer (MVR) 

− Network 

− Advanced 

− Mode 

− About Us 

− Language 

 Q8 Menu Operations 

− Startup and Shutdown 

− Home Screen 

 Note:  

All menu pictures shown in this chapter are for illustration purposes only. Actual 
product may vary.  
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P20/P10 Menu Operations 

The 5-inch LCD and a variety of buttons on the front panel of the P20/P10 allow for 
pretty darn simple operations. The following sections will introduce the operations in 
detail. 

6.1.1 Startup and Shutdown 

Connect all the necessary cables and power cords properly, locate and turn on the 
rocker switch on the rear panel. The startup screen appears, as shown in Figure 6-1. 
The P20/P10 front panel provides a 5-inch LCD screen allowing for more intuitive 
operations. 

 Startup screen 

 

To turn off the P20/P10, press the power button on the front panel and select OK 
from the dialog box displayed on the LCD screen. 

6.1.2 Home Screen  

After the startup, the home screen is displayed. The following descriptions use the 
P20 home screen as an example, as show in Figure 6-2 and Table 6-1. 
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 Home screen (P20) 

 

Table 6-1 Home screen description 

No. Description 

1 Displays the device information. 

 
Logo of PIXELHUE 

P20 Device model 

SYSTEM Device name 

 Front panel lock 

 When this icon is displayed, the front panel buttons are 
locked. 

 When this icon is not displayed, the front panel buttons 
are unlocked. 

Press and hold the knob and BACK button simultaneously 
for 3s or longer to lock or unlock the front panel buttons. 

192.168.100.100 Device IP address 

For details, see 6.1.9 Network. 

 
Connection status of the Ethernet port on the rear panel 

 : An Ethernet cable is connected. 

 : No Ethernet cable is connected 

 
Connection status of the USB drive on the front panel 

 : A USB drive is inserted. 

 : No USB drive is inserted. 

2 LAYER Displays the statuses of layers and their input sources. 

Layer status: 

 When a layer icon is in green, the layer is open. 



Event Presentation Switching Solution User Manual 6 Menu Operations 

 

www.pixelhue.com 39 
 

No. Description 

 When a layer icon is in gray, the layer is closed. 

Input source status:  

 When an input source name is displayed, it indicates that 
the source is selected. When the source name is in green, 
the source is normal. When the source name is in gray, it 
indicates no signal. 

 When N/A is displayed, no input source is selected and 
the layer is blank. 

For details, see 6.1.5.1.1 Set Basic Properties. 

3 AUX Displays the statuses of AUX layers and their input sources. 

Layer status: 

 When an AUX icon is in green, the AUX layer is open. 

 When an AUX icon is in gray, the AUX layer is closed. 

Input source status: 

 When an input source name is displayed, it indicates that 
the source is selected. When the source name is in green, 
the source is normal. When the source name is in gray, it 
indicates no signal. 

 When N/A is displayed, no input source is selected and 
the layer is blank. 

For details, see 6.1.5.2 Set AUX Layers. 

4 OPT Displays the connection statuses of the optical fiber ports 
on the rear panel. 

 When an OPT port icon is in green, an optical fiber cable is 
connected. 

 When an OPT port icon is in blue, no optical fiber cable is 
connected. 

5 OUTPUT Displays the output connector statuses. 

 When an output connector icon is in green, an output 
device is connected. 

 When an output connector icon is in blue, no output device 
is connected. 

 When the border of an output connector icon is in orange, 
the connector is used for copying output. 

6 BACKUP Device backup on/off 

GENLOCK Signal synchronization status 

For details, see 6.1.10.1 Set Synchronization Signal Source. 

DISPLAY Display status 

 NORMAL: The source is being displayed normally. 

 FTB: The screen fades to black. 

 FRZ: The source is frozen at the current frame. 

For details, see 6.1.6.1 Set Display Status. 

PGM EDIT PGM edit on/off 
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No. Description 

For details, see 6.1.10.2 Turn on/off PGM Edit. 

BKG BKG on/off 

For details, see 6.1.5.3 Manage BKG. 

7 SCREEN Screen resolution 

For details, see 6.1.4.2 Set Output Resolution. 

LAYOUT Screen layout 

For details, see 6.1.4.4 Set Mosaic. 

MODE Working mode of the device 

 Switcher 

 PGM Only 

For details, see 6.1.11 Mode. 

On the home screen, press the knob to access the main menu screen and complete 
relevant settings. The following sections will describe menu operations in detail. 

 Main menu (P20) 

 

6.1.3 Input 

The Input menu allows you to do the following: 

 Select Connector Type 

 Select Connector Capacity 

 Set EDID 

 Import and Export EDID 

 Set Input Color 

 Set InfoFrame Override 

 Set HDCP 
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Select Connector Type 

Select the desired input connector to use it as the input source. 

Prerequisites 

 For a DP 1.2/HDMI 2.0 input, only one connector can be selected as the input 
source at the same time.  

 Connector type selection is not available for the 12G-SDI connectors. 

Notes: 

After the input connector is changed: 

 The layers on the common screen and AUX screen become blank. 

 The connector properties such as the resolution and color settings are reset to 
the defaults. 

Menu Orientation 

On the main menu screen, scroll to and select Input > Connector. 

 Input connector selection (P20) 

 

Description 

Menu Item Description 

Input Source  Select an input source. 

 P20 

Includes 12x input sources. Inputs 1 to 8 contain 8x DP 1.2/HDMI 2.0 
and Inputs 9 to 12 contain 4x 12G-SDI. 

 P10 

Includes 6x input sources. Inputs 1 to 4 contain 4x DP 1.2/HDMI 2.0 
and Inputs 5 to 6 contain 2x 12G-SDI. 

Connector Select the type of the input connector. Either DP 1.2 or HDMI 2.0 can be 
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Menu Item Description 

selected.  

Select Connector Capacity 

Select a connector capacity so that the device can calculate the number of layers 
that can be added on the common screen according to the selected connector 
capacity. 

Prerequisites 

An input source and connector type are selected. Connector type selection is not 
available for 12G-SDI. 

Notes 

After the connector capacity is changed: 

 The layers on the common screen become blank and the DSK function is turned 
off. 

 The connector properties such as the resolution and color settings are reset to 
the defaults. 

Menu Orientation 

On the main menu screen, scroll to and select Input > Capacity. 

 Connector capacity selection (P20) 

 

Description 

Menu Item Description 

Capacity Resource usage of the input connector 

 SL: 2K×1K 

 4K: 4K×2K 
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Set EDID 

Set input resolution and frame rate. You can either choose a standard resolution 
provided by the system or customize a resolution, and set advanced parameters. 

Prerequisites 

 The video source is output by graphics card. 

 An input source and connector type (DP 1.2/HDMI 2.0) are selected. EDID 
settings are not available for the 12G-SDI connectors. 

Notes 

Advanced settings must be done by trained professionals. 

Menu Orientation 

On the main menu screen, scroll to and select Input > Input Resolution. 

 Input resolution settings (P20) 

 

Description 

Menu Item Submenu Item Description 

Current Resolution - Current input resolution: Pixel width and 
height of the input source 

Standard Resolution Commonly used resolution 

Frame Rate Commonly used frame rate 

Frames per second (Hz) 

Custom Width Pixel width of the input source 

Height Pixel height of the input source 

Frame Rate Frames per second (Hz) 
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Menu Item Submenu Item Description 

Advanced Frame Rate Frames per second (Hz) 

H Total The total number of pixels per line 

Width Pixel width of the active area 

H Front Porch The offset between the end of the active area 
and the beginning of H sync 

H Sync H sync width in pixels 

H Polarity Polarity (active high or low) of the horizontal 
sync pulse 

V Total The total number of pixels per frame 

Height Pixel height of the active area 

V Front Porch The offset in lines between the end of the 
output active area and the beginning of V 
sync 

V Sync V sync width in lines 

V Polarity Polarity (active high or low) of the vertical 
sync pulse 

After the settings are completed, select Apply for the settings to take effect. 

Import and Export EDID 

When there is something wrong with the input connector compatibility, import EDID 
files without compatibility problems into the device. Or export EDID files from the 
device and provide the files for other devices or input connectors to solve 
compatibility problems. 

Prerequisites 

 Before importing an EDID file, copy the file (.bin and .dat) to the root directory of 
a USB drive and insert the USB drive into the USB port on the front panel of the 
P20/P10. 

 Before exporting an EDID file, insert a USB drive into the front panel of the 
P20/P10. 

 An input source and connector type are selected. EDID import and export are not 
available for 12G-SDI. 

Notes 

 The USB port on the P20/P10 front panel does not support USB HUB. 

 Only one EDID file can be imported for an input connector and the file must be 
less than 1 MB. 

Menu Orientation 

On the main menu screen, scroll to and select Input > Input Resolution > Import 
EDID/Export EDID. 
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 EDID import/export (P20) 

 

Description 

 Import EDID 

a. Scroll to and select Import EDID to access the EDID file screen. 

b. Select the file to be imported. 

c. In the dialog box that appears, select OK. 

 Export EDID 

a. Scroll to and select Export EDID to access the submenu. 

b. From the drop-down options, select a file format (.bin or .dat). 

c. Select Apply. 

 Note:  

If you want to modify the content of an imported EDID file, modify the file, import it 
again and overwrite the original one.  

Set Input Color 

Set the color parameters of an input connector so that the color effect can be applied 
to all the video sources accessed from this connector. 

Prerequisites 

An input source and connector type are selected. Input color settings are not 
available for the 12G-SDI connectors. 

Menu Orientation 

On the main menu screen, scroll to and select Input > Input Color. 
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 Input color settings (P20) 

 

Description 

Menu Item Description 

Brightness Brightness is the shading of lights in the image. When the brightness 
increases, viewers will be dazzled. When the brightness decreases, the 
image becomes dark. 

Contrast Contrast is the ratio of the luminance of the brightest color to that of 
the darkest color. Generally, the higher the contrast, the clearer and 
more colorful the image. On the contrary, the entire image becomes 
gloomy. Contrast affects the exposure level of the entire image. It 
makes the bright part brighter and the dark part darker. 

Saturation Saturation is the colorfulness of the image. The higher the contrast, 
the more vivid the image. 

Hue Hue is the relative degree of how bright or dark the image is. 

If you want to reset the parameters to their default values, select Apply. 

Set InfoFrame Override 

Set the override parameters of the input source. The parameters can be used by the 
device for calculation. This operation does not change the original parameter values 
of the input source. 

Prerequisites 

An input source and connector type (DP 1.2/HDMI 2.0) are selected. InfoFrame 
override settings are not available for the 12G-SDI connectors. 

Note 

The P10 does not support dynamic range conversion and the related parameters are 
not displayed on the menu. 
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Menu Orientation 

On the main menu screen, scroll to and select Input > InfoFrame Override. 

 InfoFrame Override (P20) 

 

Description 

Menu Item Description 

Dynamic 
Range 
Conversion 

Turn on/off dynamic range conversion 

This function enables free conversion between SDR, HDR10 and HLG. 

 : On 

 : Off 

Color/Sample Set the input color space and sampling rate 

Bit Depth Set the input bit depth 

Bit depth refers to the color information stored in an image. The higher 
the bit depth of an image, the more colors it can store. 

Quantization 
Range 

Set the input quantization range 

Dynamic 
Range 

Convert the dynamic range. Free conversion between SDR, HDR10 and 
HLG is supported. 

This menu item is displayed only when Dynamic Range Conversion is 
turned on ( ). 

Color Gamut Set the input color gamut standard 

This menu item is displayed only when Dynamic Range Conversion is 
turned on ( ). 

When you set a parameter value to AUTO, the device will get the actual value from 
the properties of the input source automatically. 
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Set HDCP 

HDCP (High-Bandwidth Digital Content Protection) is a coding scheme used to 
protect audio and video signals traveling through DVI, HDMI, and DP from being 
copied and illegally intercepted during a streaming session. Users can turn on/off 
HDCP for input connectors. HDCP is turned on by default. 

Prerequisites 

An input source and connector type are selected. 

Note 

SDI does not support HDCP. If 12G-SDI is select as the input source, the HDCP 
function will be unavailable. 

Menu Orientation 

On the main menu screen, scroll to and select Input > HDCP. 

 HDCP (P20) 

 

Description 

Select On or Off to turn on or off HDCP function for the input source. 

6.1.4 Output 

The Output menu allows you to do the following: 

 Select Output Capacity 

 Set Output Resolution 

 Export EDID 

 Set Mosaic 

 Set Output Color 

 Set Output Information 
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 Set HDCP 

Select Output Capacity 

Set the output capacity of the common screen to 4K or SL. 

Prerequisites 

The device is the P10. Output capacity selection is available for the P10 only. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Output Capacity. 

 Output capacity (P10) 

 

Description 

Menu Item Description 

Output Select an output for settings. 

 Output: Primary output 

 AUX: AUX output 

Select Output. Output capacity selection is not available for AUX 
output. 

Output Capacity Select the output capacity of the common screen. 

 SL: 2K×1K 

 4K: 4K×2K 

Set Output Resolution 

Set the resolution and frame rate of the common screen. You can select a standard 
resolution provided by the system or customize a resolution, and complete advanced 
settings. 
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Prerequisites 

 The EDID information of the connected device is obtained. 

 Output is selected as the output. The resolution of AUX outputs is not settable 
and fixed at 1920×1080@60Hz. 

Note 

 Advanced settings must be done by trained professionals. 

 After the output resolution is changed, the AOI parameters related to the 
connector are reset to defaults. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Output Resolution. 

 Output resolution settings (P20) 

 

Description 

Menu Item Submenu Item Description 

Current Resolution - Current resolution: Pixel width and height of 
the output image 

Standard Resolution Commonly used resolution 

Frame Rate Commonly used frame rate, 

Frames per second (Hz) 

Custom Width Pixel width of the output image 

Height Pixel height of the output image 

Frame Rate Frames per second (Hz) 

Advanced Frame Rate Frames per second (Hz) 

H Total The total number of pixels per line 
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Menu Item Submenu Item Description 

Width Pixel width of the active area 

H Front Porch The offset between the end of the active area 
and the beginning of H sync 

H Sync H sync width in pixels 

H Polarity Polarity (active high or low) of the horizontal 
sync pulse  

V Total The total number of pixels per frame 

Height Pixel height of the active area 

V Front Porch The offset in lines between the end of the 
output active area and the beginning of V 
sync 

V Sync V sync width in lines 

V Polarity Polarity (active high or low) of the vertical 
sync pulse 

After the settings are completed, select Apply for the settings to take effect. 

Export EDID 

When the input connectors of the connected device has good EDID compatibility, the 
P20/P10 can learn the EDID of the connected device via the output connectors and 
the EDID information can be exported to a USB drive so that other input connectors 
of the connected device can use the EDID information. 

Prerequisites 

 A USB drive is inserted into the USB port on the front panel of the P20/P10. 

 The input connectors and the connected device are connected correctly. 

 Output is selected as the output. EDID export is not available for AUX outputs. 

Note 

The USB port on the front panel of the device does not support USB HUB. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Output Resolution > Export 
EDID. 
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 EDID learning (P20) 

 

Description 

Select Export EDID to access the submenu, then select a file format (.bin or .dat) and 
output connector, and select Apply to export the EDID information to the root 
directory of the USB drive. 

Set Mosaic 

Set screen mosaic by using easy mode or advanced mode. 

Prerequisites 

On the output setting menu, Output is set to Output. Mosaic settings are not available 
for AUX outputs. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Mosaic Settings. 

 Mosaic settings (P20) 

 

Description 

Menu Item Description 

Mode Select a mode for mosaic settings 

 Easy: Set the total screen width and height. The P20/P10 will 
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Menu Item Description 

calculate a mosaic plan automatically. After the mosaic plan is 
changed, AOI parameters will be reset. 

 Advanced: Select a mosaic layout template (the number of rows 
and columns of the output connectors) and set AOI parameters. 

Total Width Pixel width of the screen 

This parameter is displayed when the Easy mode is selected. 

After you select Apply, this parameter value keeps the same as the 
value in the mosaic plan. 

Total Height Pixel width of the screen 

This parameter is displayed when the Easy mode is selected. 

After you select Apply, this parameter value keeps the same as the 
value in the mosaic plan. 

Mosaic Layout Rows and columns of output connectors on the screen 

This menu item is displayed only when Advanced is selected as the 
mosaic mode. 

Number of output connectors that can be used for mosaic: 

 P20 

− In PGM only mode, four output connectors can be used for 
mosaic. 

− In switcher mode, two output connectors can be used for 
mosaic. 

 P10 

− 4K: In PGM only mode, two connectors can be used for 
mosaic. In switcher mode, one connector can be used. 

− SL: In PGM only mode, eight connectors can be used for 
mosaic. In switcher mode, four connectors can be used. 

Replace 
Connector 

If an output connector used on the mosaic layout fails, you can 
replace the connector with another normal connector via menu 
operations. 

Procedure: 

Select Replace Connector, select the connector to be replaced on the 
right, scroll to and select another normal connector. 

If the selected normal connector is in use, the normal connector and 
the failed connector will be swapped. 

AOI Settings Set the pixel width and height and start position of the output 
connector on the mosaic screen.  

This menu item is displayed only when Advanced is selected as the 
mosaic mode. 

When the resolution of the output connector is higher than the actual 
screen resolution, AOI settings allow the output connector to meet 
the mosaic requirements without changing the original resolution of 
the connector. 

Submenu description: 

 Connector: Select the connector for AOI settings. 

 Width: Set the pixel width. 
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Menu Item Description 

 Height: Set the pixel height 

 H Position: Set the horizontal start position. 

 V Position: Set the vertical start position. 

Set Output Color 

Set output color parameters. The final output color is the combination of layer color, 
input color and output color. 

Prerequisites 

On the output setting menu, Output is set to Output or AUX. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Output Color. 

 Output color settings (P20) 

 

Description 

Menu Item Description 

Brightness Brightness is the shading of lights in the image. When the brightness 
increases, viewers will be dazzled. When the brightness decreases, the 
image becomes dark. 

Contrast Contrast is the ratio of the luminance of the brightest color to that of 
the darkest color. Generally, the higher the contrast, the clearer and 
more colorful the image. On the contrary, the entire image becomes 
gloomy. Contrast affects the exposure level of the entire image. It 
makes the bright part brighter and the dark part darker. 

Saturation Saturation is the colorfulness of the image. The higher the contrast, 
the more vivid the image. 

Hue Hue is the relative degree of how bright or dark the image is. 
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Set Output Information 

Set the parameters relating to the output signal. 

Prerequisites 

On the output setting menu, Output is set to Output or AUX. 

Note 

The P10 does not support dynamic range conversion and the related menu items are 
not displayed on the menu. 

Menu Orientation 

On the main menu screen, scroll to and select Output > Output Information. 

 Output information (P20) 

 

Description 

Menu Item Description 

Dynamic 
Range 
Conversion 

Turn on /off dynamic range conversion. 

This function enables free conversion between SDR, HDR10 and HLG. 

 : On 

 : Off 

Color/Sample Set output color space and sampling rate. 

Bit Depth Set output bit depth. 

Bit depth refers to the color information stored in an image. The higher 
the bit depth of an image, the more colors it can store. 

Dynamic 
Range 

Convert the dynamic range. Free conversion between SDR, HDR10 and 
HLG is supported. 

This menu item is displayed only when Dynamic Range Conversion is 
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Menu Item Description 

turned on ( ). 

Gamma Gamma value 

This menu item is displayed only when Dynamic Range Conversion is 
turned on ( ). 

Color Gamut Set output color gamut standard. 

This menu item is displayed only when Dynamic Range Conversion is 
turned on ( ). 

Set HDCP 

HDCP (High-Bandwidth Digital Content Protection) is a coding scheme used to 
protect audio and video signals traveling through DVI, HDMI, and DP from being 
copied and illegally intercepted during a streaming session. Users can select an 
HDCP version for the output connector or turn off the HDCP function. HDCP is turned 
on by default. 

Prerequisites 

On the output setting menu, Output is set to Output or AUX. 

Menu Orientation 

On the main menu screen, scroll to and select Output > HDCP. 

 HDCP (P20) 

 

Description 

Select an HDCP version, or select Off to turn off HDCP. 

6.1.5 Layer 

The Layer menu allows you to do the following: 

 Set Regular Layers 
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 6.1.5.2 Set AUX Layers 

 Manage BKG 

 Manage LOGO 

Set Regular Layers 

Settings of a regular layer include layer status, input source, aspect ratio, pixel width 
and height, horizontal and vertical start position, scaling mode, Z-order, layer freeze, 
input crop, layer color, DSK, layer mask, layer flipping, etc. The following will describe 
the settings in detail. 

6.1.5.1.1 Set Basic Properties 

Set the basic properties of a regular layer. 

Note 

If the input source assigned to a regular layer exceeds the bandwidth limit, the output 
of the layer will be black. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer. 

 Regular layer settings (P20) 

 

Description 

Menu Item Description 

Layer Select a layer to set its properties. 

 P20 

The P20 supports one common screen and up to seven layers 
(3x 4K@60Hz layers and 4x 2K@60Hz layers, or 4x 4K@60Hz 
layers). 

 P10 
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Menu Item Description 

The P10 supports one common screen and up to six layers (2x 
4K@60Hz layers and 4x 2K@60Hz layers, or 4x 4K@60Hz 
layers). 

Status Set the layer status. 

When the resource limit is exceeded, the layer cannot be opened. 

 : Open 

 : Closed 

Input Source Select an input source for the layer 

Lock Aspect Ratio Lock or unlock the aspect ratio of the layer resolution. 

 : Locked 

 : Unlocked 

Aspect Ratio Set the ratio of the layer width to the layer height. 

After the aspect ratio is changed, the layer height keeps 
unchanged and the layer width is calculated automatically. 

Width Specify the layer width. 

Height Specify the layer height. 

H Position Specify the horizontal start position of the layer on the common 
screen. The coordinates of the pixel at the top left of the main 
screen is (0, 0). 

V Position Specify the vertical start position of the layer on the common 
screen. The coordinates of the pixel at the top left of the main 
screen is (0, 0). 

Scaling Mode Set the scaling mode of the layer. 

 Custom: The layer is scaled according to your settings. 

 Pixel to Pixel: The layer resolution is the same as the input 
resolution. If the input source is cropped, the layer resolution is 
the same as the resolution after cropping. 

 Full Screen: The layer fills the entire screen. 

Z-Order Set the priority order of the layer. The values of the Z-order of 
different layers cannot be the same. The greater the value, the 
higher the layer priority. 

6.1.5.1.2 Set Input Crop 

When there are black borders or unnecessary information on the input source, input 
crop allows you to crop the input source and display the desired area. 

Prerequisites 

A regular layer is selected and the input source is accessed. 

Note 

The input source status and capacity after cropping is the same as the original. 
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Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > Input Crop. 

 Input crop (P20) 

 

Description 

Menu Item Description 

Status Turn on/off input crop. 

 : On 

 : Off 

H Position Set the horizontal start position of the cropped area. 

V Position Set the vertical start position of the cropped area. 

Width Set the pixel width of the cropped area. 

Height Set the pixel height of the cropped area. 

Crop Effect Example 

 

6.1.5.1.3 Set Layer Color 

Set layer color parameters. 

Prerequisites 

A layer is selected for color settings. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > Layer Color. 



Event Presentation Switching Solution User Manual 6 Menu Operations 

 

www.pixelhue.com 60 
 

 Layer color settings (P20) 

 

Description 

Menu Item Description 

Brightness Brightness is the shading of lights in the image. When the brightness 
increases, viewers will be dazzled. When the brightness decreases, the 
image becomes dark. 

Contrast Contrast is the ratio of the luminance of the brightest color to that of 
the darkest color. Generally, the higher the contrast, the clearer and 
more colorful the image. On the contrary, the entire image becomes 
gloomy. Contrast affects the exposure level of the entire image. It 
makes the bright part brighter and the dark part darker. 

Saturation Saturation is the colorfulness of the image. The higher the contrast, 
the more vivid the image. 

Hue Hue is the relative degree of how bright or dark the image is. 

Monochrome Turn on/off monochrome. 

 : On. The layer image is in black and white. 

 : Off 

Invert Colors Turn on/off color inversion. 

 : On. The colors of the layer image is inverted. 

 : Off 

Opacity Set color opacity. 

6.1.5.1.4 Set DSK 

Use luma key or chroma key for input sources. DSK is available for the P20 only. 

Prerequisites 

 The device is P20. 

 A layer is selected for DSK and the input source is accessed. 

Note 

After DSK is turned on, the layer capacity becomes 4K automatically. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > DSK. 
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 Layer color settings (P20) 

 

Description 

Menu Item Description 

Status Turn on/off DSK. 

 : On 

 : Off 

Mode DSK mode 

 Luma key: Suitable for application scenarios where the 
brightness of the background is significantly smaller than 
that of the foreground. The result of luma key is that the 
background becomes transparent and the foreground is 
keyed out. 

 Chroma key: Suitable for application scenarios with a 
single background color, such as blue/green screen 
matting. 

Luma Clip Distinguish between the foreground and background. 

Gain Hue softness of the transition area  

The greater the value, the softer the transition. 

Foreground 
Color 

Turn on or turn off foreground color adjustment. 

 : On. The RGB of the related parameter can be set to 
adjust the keying effect. 

 : Off 

RGB RGB values of the foreground color 

Chroma Pick Hue Set the RGB values of the pick point 

 Method 1: Specify the coordinates of the pick point on 
the input source, and the RGB values of the point will be 
displayed. 

 Method 2: Specify the RGB values. 

After the settings, click Apply. You can also adjust the 
following parameters to optimize the keying effect. 

Hue Ramp Distinguish between the foreground and background. 

Hue Clip Hue range 

The greater the value, the larger the removal area. The 
maximum value is the current value of Hue Ramp. 

Saturation Clip Distinguish between the foreground and background. 
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Menu Item Description 

Saturation 
Gain 

The hue softness of the transition area  

The larger the value, the softer the transition. 

Spill Remove the overflow from the foreground image edges 
and semi-transparent areas. 

Shadow Remove the shadow areas. 

Highlight Remove the highlight areas. 

Edge Smooth Turn on or turn off edge smooth. 

 : On 

 : Off 

6.1.5.1.5 Set Layer Mask 

Set parameters related to layer mask. The masked area will be transparent and 
invisible. The layer resolution keeps unchanged. 

Prerequisites 

A layer is selected for mask settings. 

Note 

Enabling layer mask will disable the layer border. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > Mask. 

 Layer mask (P20) 

 

Description 

Menu Item Description 

Status Turn on/off layer mask. 

 : On 

 : Off 

Mask Top Set the area to be masked on the top of the layer. 

Mask Bottom Set the area to be masked on the bottom of the layer. 
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Menu Item Description 

Mask Left Set the area to be masked on the left of the layer. 

Mask Right Set the area to be masked on the right of the layer. 

Mask Effect Example 

 

6.1.5.1.6 Set Layer Borders 

Set the border of a layer. 

Prerequisites 

A layer is selected for border settings. 

Note 

Enabling layer mask will disable the layer border. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > Border. 

 Layer border (P20) 

 

Description 

Menu Item Description 

Status Turn on/off layer border. 

 : On 

 : Off 

Border Fixed to Hard. 
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Menu Item Description 

Width Set the width of the left and right borders. 

Height Set the height of the top and bottom borders. 

Color Set the RGB of the border color. 

Border Effect Example 

 

6.1.5.1.7 Set Layer Flipping 

Flip layers horizontally, vertically, or horizontally and vertically. 

Prerequisites 

A layer is selected for flipping. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > Regular Layer > Flip. 

 Layer flipping (P20) 

 

Description 

Menu Item Description 

Flip  None: Don’t flip the layer. 

 Flip Horizontally: Flip the layer horizontally. 

 Flip Vertically: Flip the layer vertically. 

 Flip Horizontally and Vertically: Flip the layer horizontally and 
vertically 
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Flipping Effect Example 

 

Set AUX Layers 

Set the layer status of an AUX screen and assign a layer source. 

Note 

 An AUX layer fills the entire screen and cannot be resized and repositioned. 

 When the layer source exceeds the resource limit, the output of the layer is a 
black screen. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > AUX Layer. 

 AUX layer (P20) 
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Description 

Menu Item Description 

Layer Select an AUX layer for settings. 

AUX screens are used for displaying auxiliary signals such as 
teleprompters. 

 P20 

The P20 supports four AUX screens and each screen supports one 
layer at most. AUX1 and AUX3 share 2x 4K resources and AUX2 
and AUX4 share 2x 4K resources. For example, if AUX1 uses 2x 4K 
resources, no layers cannot be added to AUX3. 

 P10 

The P10 supports two AUX screens and each screen supports one 
layer at most. AUX1 and AUX2 share 2x 4K resources. For example, 
if AUX1 uses 2x 4K resources, no layers cannot be added to AUX2. 

Status Turn on/off layer. 

 : On 

 : Off 

Input Source Assign an input source or PGM to the AUX layer. 

Manage BKG 

Apply, export, delete and import BKG files, and save captured images as BKG files. 

Prerequisites 

 Before importing a BKG file, copy the file (.png, .bmp, .jpg, .jpeg) to the root 
directory of a USB drive and insert the USB drive into the USB port on the front 
panel of the P20/P10. 

 Before exporting a BKG file, insert a USB drive into the USB port on the front 
panel of the P20/P10. 

Notes 

 The USB port on the front panel of the P20/P10 does not support USB HUB. 

 The BKG does not use the layer resources. 

 The BKG image automatically fits to the screen and is always at the back of the 
layer order. 

 When you are importing a BKG file using the event controller or PixelFlow, you 
are not able to import BKG images using the P20/P10. 

 The total number of BKG and LOGO files cannot exceed 255 and the total 
storage space for BKG and LOGO files is up to 512 MB. 

 The maximum resolution of a single BKG file is 65536×65536 pixels. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > BKG. 
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 BKG (P20) 

 

Description 

 Apply BKG 

a. Turn on BKG. ( ) 

b. Select BKG to open the BKG file screen. 

c. Select a BKG file. In the dialog box that appears, select Apply to use the BKG 
file as the background image of the common screen. 

 Export BKG 

a. Turn on BKG. ( ) 

b. Select BKG to open the BKG file screen. 

c. Select a BKG file. In the dialog box that appears, select Export. 

d. In the dialog box that appears, select OK to export the BKG file to the root 
directory of the USB drive. 

 Delete BKG 

a. Turn on BKG. ( ) 

b. Select BKG to open the BKG file screen. 

c. Select a BKG file. In the dialog box that appears, select Delete. 

d. In the dialog box that appears, select OK to delete the BKG file. 

 Import BKG 

a. Select BKG Import to open the BKG file list screen. 

b. Select a BKG file. In the dialog box that appears, select OK to import the 
BKG file. 

 Capture 

a. Select Capture to access the submenu. 

b. From the drop-down options, select PGM or an input source for capture. 

c. Select Capture. 

d. After an image is captured successfully, select Save to save the captured 
image as a BKG file. 
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Manage LOGO 

Apply, export, delete and import LOGO files. 

Prerequisites 

 Before importing a LOGO image, copy the LOGO file (.png, .bmp, .jpg, .jpeg) to 
the root directory of a USB drive and insert the USB drive into the USB port on the 
front panel of the P20/P10. 

 Before exporting a LOGO image, insert a USB drive into the USB port on the front 
panel of the P20/P10. 

Notes 

 The USB port on the front panel of the P20/P10 does not support USB HUB. 

 LOGO does not use the layer resources. 

 The LOGO image is always at the front of the layer order and cannot be resized. 
You can change the position of the BKG image. 

 When you are importing a LOGO file using the event controller or PixelFlow, you 
are not able to import LOGO files using the P20/P10. 

 The total number of BKGs and LOGOs cannot exceed 255 and the total storage 
space for BKG and LOGO files is up to 512 MB. 

 The maximum resolution of a single LOGO file is 512×512 pixels. 

Menu Orientation 

On the main menu screen, scroll to and select Layer > LOGO. 

 LOGO (P20) 

 

Description 

 Apply LOGO 

a. Turn on LOGO. ( ) 
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b. Select LOGO to open the LOGO file screen. 

c. Select a LOGO file. In the dialog box that appears, select Apply to use the 
LOGO file as the LOGO of the common screen. 

d. Go back to the previous menu. 

e. Specify H Position and V Position to set the position of the LOGO on the 
screen, that is the horizontal and vertical start position relative to the top left 
(0,0) of the screen. 

 Export LOGO 

a. Turn on LOGO. ( ) 

b. Select BKG to open the LOGO file screen. 

c. Select a LOGO file. In the dialog box that appears, select Export. 

d. In the dialog box that appears, select OK to export the LOGO file to the root 
directory of the USB drive. 

 Delete LOGO 

a. Turn on LOGO. ( ) 

b. Select LOGO to open the LOGO file screen. 

c. Select a LOGO file. In the dialog box that appears, select Delete. 

d. In the dialog box that appears, select OK to delete the LOGO file. 

 Import LOGO 

a. Select LOGO Import to open the LOGO file screen. 

b. Select a LOGO file. In the dialog box that appears, select OK to import the 
LOGO file. 

6.1.6 Display 

The Display menu allows you to do the following: 

 Set Display Status 

 Set Test Patterns 

 Switch from PVW to PGM 

Set Display Status 

Make the common screen display content normally, fade to black, or freeze the 
current frame of the input source. 

Menu Orientation 

On the main menu screen, scroll to and select Display. 
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 Display control (P20) 

 

Description 

Menu Item Description 

Normal The screen displays content normally. 

FTB The screen fades to black and the input source is still playing. 

Freeze The current frame of the input source is frozen on the screen and the 
input source is still playing. 

After a display status is selected, ✓ appears on the right. 

Set Test Patterns 

Test patterns are used for checking whether content can be displayed correctly. 

Menu Orientation 

On the main menu screen, scroll to and select Display > Test Pattern. 
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 Test pattern (P20) 

 

Description 

Menu Item Description 

Pure Color Test pattern color 

Gradient Gradient style of the test pattern  

Grid Grid style of the test pattern 

Brightness Test pattern brightness 

Spacing Level Spacing between different colors 

This option is displayed only when the test pattern contains multiple 
colors. 

Spacing (px) Spacing between grid lines 

This option is displayed only when the grid style is specified. 

Line Width Width of grid lines 

This option is displayed only when the grid style is specified. 

Speed Moving speed of grid lines 

This option is displayed only when the grid style is specified. 

Switch from PVW to PGM 

Select a mode to switch content from PVW to the PGM. 

Prerequisites 

The device is in switcher mode. Switching mode selection is not available in PGM 
only mode. 

Menu Orientation 

On the main menu screen, scroll to and select Display. 
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 Display control (P20) 

 

Description 

Menu Item Description 

Switching 
Mode 

Select a mode to switch content from PVW to PGM. 

 SWAP: The contents on PVW and PGM are swapped after the 
switching. 

 COPY: The content on PVW are copied to PGM after the switching. 

Transition 
Effect 

Select a transition effect. 

 Cut: Switch content from PVW to PGM with no transition effect. 

 Fade: Switch content from PVW to PGM with a fade effect. 

Duration Duration of the transition effect. 

6.1.7 Preset 

Save the content on PVW or PGM as a preset, load and delete presets. 

Note 

A maximum of 128 presets can be saved. 

Menu Orientation 

On the main menu screen, scroll to and select Preset. 
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 Display control (P20) 

 

Description 

 Save from PVW 

Select a blank preset and select Save from PVW from the dialog box that 
appears to save the content on PVW as a preset. 

After the preset is saved successfully, the status of the preset changes to Saved. 

 Save from PGM 

Select a blank preset and select Save from PGM from the dialog box that 
appears to save the content on PGM as a preset. 

After the preset is saved successfully, the status of the preset changes to Saved. 

 Load a preset 

Select a saved preset and select Load from the dialog box that appears to use 
the preset on the screen. 

 Delete a preset 

Select a saved preset and select Delete from the dialog box that appears to clear 
the content in the preset. 

6.1.8 Multiviewer (MVR) 

Set the layout on the Multiviewer screen. 

Note 

 The resolution of the Multiviewer screen is fixed at 1920×1080@60Hz. 

 If the input source exceeds the bandwidth limits, the Multiviewer monitor will 
display a black screen. 

Menu Orientation 

On the main menu screen, scroll to and select MVR. 
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 Multiviewer (P20) 

 

Description 

Menu Item Description 

MVR Layout Select a layout for Multiviewer screen. 

 Switcher mode: Four layout templates are provided. 

− Layout1 and Layout2 are suitable for 1920×1080 screens. 

− Layout3 is suitable for ultra-wide screens. 

− Layout4 is suitable for ultra-high screens. 

 PGM only mode: Three layout templates are provided. 

− Layout1 is suitable for 1920×1080 screens. 

− Layout2 is suitable for ultra-wide screens. 

− Layout3 is suitable for ultra-high screens. 

After a Multiviewer layout is selected, all the accessed input sources 
are displayed on the Multiviewer windows automatically. 

HDCP Select an HDCP version or turn off HDCP. 

6.1.9 Network 

Manually specify a static IP address for the device or set the device to obtain an IP 
address automatically. 

Menu Orientation 

On the main menu screen, scroll to and select Network. 
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 Network settings (P20) 

 

Description 

Menu Item Description 

MAC Address Display the physical address of the device. 

Network Mode Select an IP address configuration method. 

 Manual: Specify a static IP address for the device manually. 

 Auto: The device obtains an IP address automatically. 

IP Address IP address of the device 

Subnet Mask Subnet mask of the device 

Default Gateway Default gateway address of the current device 

If you want to reset the parameters to their default values, select Reset. 

6.1.10 Advanced 

The Advanced menu allows you to do the following: 

 Set Synchronization Signal Source 

 Turn on/off PGM Edit 

 Set Input Backup 

 Return to Home 

 Set Fn Button 

 Reset to Factory Settings 

 Run Diagnostics 

 Import and Export Project Files 

 Update Firmware 

 Export Logs 
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Set Synchronization Signal Source 

Select a synchronization signal source for the output signal. 

Prerequisites 

Before Genlock settings, the synchronization signal source is connected to the 
Genlock connector on the rear panel of the P20/P10. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Synchronization. 

 Synchronization signal source (P20) 

 

Description 

Menu Item Description 

Status Turn on/off synchronization. 

 : On 

 : Off 

Source Select a synchronization source. 

 Genlock: Sync to the frame frequency of the Genlock input signal. 

 Input X: Sync to the frame frequency of the selected input source. X 
stands for the input source number. 

Turn on/off PGM Edit 

Turn on or off PGM edit. 

Prerequisites 

The P20/P10 is in switcher mode. PGM edit is not available in PGM only mode and is 
turned on by default. 
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Menu Orientation 

On the main menu screen, scroll to and select Advanced > PGM Edit. 

 PGM edit (P20) 

 

Description 

Menu Item Description 

PGM Edit Turn on/off PGM edit. 

 : On 

The edits you make on the LCD menu modify the layers on PGM 
and the edit process is displayed on the screen in real time. 

 : Off 

The edits you make on the LCD menu modify the layers on PVW. 

Set Input Backup 

Set input source backup relationships. When the primary source fails, the backup 
source takes over automatically without downtime. 

Note 

 The capacity of the primary and backup input connectors must be the same. 

 After input backup settings, the capacity and type of the related connectors 
cannot be changed. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Input Backup. 
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 Input backup (P20) 

 

Description 

Menu Item Description 

Status Turn on/off input source backup. 

 : On. When the current source has no signal, the backup source 
takes over automatically. 

 : Off 

Primary 
Preferred 

Turn on/off primary source preferred. 

 : On. The primary source is preferred.  

 : Off 

From the drop-down options on the left and right, select primary and backup sources 
to establish input backup relationships. 

If you want to reset Primary Preferred status and all backup relationships to the 
defaults, select Reset. 

Return to Home 

Set the period during which the system stays at the current screen before returning to 
the home screen automatically when no operation is performed. 

Note 

If a dialog box is displayed, the system will not return to the home screen 
automatically after the specified period of time. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Return to Home. 
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 Return to Home (P20) 

 

Description 

Scroll to Return to Home and press the knob to make the parameter value editable. 
Rotate the knob to adjust the parameter to the desired value and press the knob to 
apply the parameter. 

Set Fn Button 

Assign a function to the FN shortcut button on the front panel of the P20/P10 so that 
users can quickly access the assigned function. Functions that can be assigned to 
the FN button include turning on/off Genlock synchronization, freeze, FTB, going to 
the test pattern or capture screen. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Fn. 

 FN button settings (P20) 
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Description 

Select Fn to access the submenu. Select Synchronization, Freeze, FTB, Test Pattern 
or Capture to assign the selected function to the FN button. 

Reset to Factory Settings 

Reset the P20/P10 parameter settings to the factory defaults. 

Note 

 This action does not change the firmware version of the device. 

 Do not disconnect the power supply during the process. 

 After factory reset, the device restarts automatically. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Factory Reset. 

 Factory reset (P20) 

 

Description 

 Keep User Data 

Reset all the parameters to their default values except the network parameters, 
project files, EDID files, gallery files, and display language. 

a. Select Factory Reset to access the submenu. 

b. Select Keep User Data. 

c. Select OK in the dialog box that appears. 

 Reset All 

Reset all the parameters to default values, except network parameters and 
project files. 

a. Select Factory Reset to access the submenu. 

b. Select Reset All. 
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c. Select OK in the dialog box that appears. 

Run Diagnostics 

Run diagnostics for the P20/P10 to identify and troubleshoot problems. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Diagnostics. 

 Diagnostics (P20) 

 

Description 

Select Diagnostics to access the submenu and select Run. After the diagnostics, 
view the result. 

Import and Export Project Files 

Import project files from a USB drive to the P20/P10 and export project files from the 
P20/P10 to a USB drive. A project file contains configuration files and data. 

Prerequisites 

 Before importing a project file, copy the file (.uprj) to the root directory of a USB 
drive and insert the USB drive into the USB port on the front panel of the 
P20/P10. 

 Before exporting a project file, insert a USB drive into the USB port on the front 
panel of the P20/P10. 

Notes 

The USB port on the front panel of the P20/P10 does not support USB HUB. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Project File. 
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 Project file (P20) 

 

Description 

 Import a project file 

a. Select Project File to access the submenu. 

b. Select Import Project File to open the project file screen. 

c. Select a project file. 

d. In the dialog box that appears, select OK to import the project file in the root 
directory of the USB drive. 

 Export a project file 

a. Select Project File to access the submenu. 

b. Select Export Project File. 

c. In the dialog box that appears, select OK to export the project file to the root 
directory of the USB drive. 

Update Firmware 

Update the firmware of the P20/P10. 

Prerequisites 

Before firmware update, copy the update file (.img) in the root directory of a USB 
drive and insert the USB drive into the USB port on the front panel of the P20/P10. 

Notes 

 The USB port on the front panel of the P20/P10 does not support USB HUB. 

 After firmware update, the device restarts automatically. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Update. 
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 Firmware update (P20) 

 

Description 

Select Update to open the update file screen. Select a file and select OK in the dialog 
box that appears. 

Export Logs 

Export logs from the P20/P10 to a USB drive. 

Prerequisites 

A USB drive is inserted into the USB port on the front panel of the P20/P10. 

Notes 

The USB port on the front panel of the P20/P10 does not support USB HUB. 

Menu Orientation 

On the main menu screen, scroll to and select Advanced > Log Export. 
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 Exporting logs (P20) 

 

Description 

Select Log Export to access the submenu. Select Apply to export the log files to the 
root directory of the USB. 

6.1.11 Mode 

Set the working mode of the device to switcher or PGM only. 

Menu Orientation 

On the main menu screen, scroll to and select Mode. 

 Working mode (P20) 

 

Description 

Select Switcher or PGM Only. After a working mode is selected, ✓ appears on the 
right. 
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6.1.12 About Us 

View the P20/P10 firmware version, the email address and official website of 
PIXELHUE. 

Menu Orientation 

On the main menu screen, scroll to and select About Us. 

 About us (P20) 

 

6.1.13 Language 

Set the display language of the menu. English and Simplified Chinese are available. 

Menu Orientation 

On the main menu screen, scroll to and select Language. 

 Language 
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Description 

Select English or 简体中文. After a language is selected, ✓ appears on the right. 

Q8 Menu Operations 

6.2.1 Startup and Shutdown 

Connect all the necessary cables and at least two power cords properly, and press 
the power button on the front panel to power on the Q8. 

To turn off the Q8, press the power button on the front panel and select OK from the 
dialog box displayed on the LCD screen. 

6.2.2 Home Screen 

After the startup, the home screen is displayed. 

 Home screen 

 

Table 6-2 Home screen description 

No. Content Description 

1 Information 
bar 

 : Device manufacturer logo. 

 Q8: Device model. 

 SHEBEIMINGCHENG: Device name, which can be modified on 
the control computer. 

 192.168.0.10: Device IP address, which can be modified on 
the device LCD or the control computer. 

: Turn off LCD display. 

2 Input card Show the input card and its connector status. 
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No. Content Description 

information   Green: The connector is accessed with a source and the 
source is normal. 

 White: The connector is not accessed with source. 

 Gray: The connector is unavailable. 

 Orange: The connector’s accessed source is abnormal. 

3 Output card 
information 

Show the output card and its connector status. 

 Green connector: The connector is connected to the backend 
device. 

 White connector: The connector is not connected to the 
backend device. 

 Gray connector: The connector is unavailable. 

4 Power 
connector 

Show the power supply connection status. 

 Green: The connector is connected with a power supply and 
the power is supplied. 

 White: The connector is not connected with a power supply 
and the power is not supplied. 

5 Control card 
connector 

Show the control card connector status. 

 Green: The connector is connected and works normally. 

 White connector: The connector is not connected or works 
abnormally. 

6 Voltage 
status 

Show the device working voltage status. 

 Normal: The voltage of each module in the device is normal. 

 Abnormal: The voltage of one or some modules in the device 
is abnormal, and the device needs troubleshooting. 

7 Temperature 
status 

Show the device working temperature status. 

 Normal: The temperature of each module in the device is 
normal. 

 Abnormal: The temperature of one or some modules in the 
device is too high, and the device needs troubleshooting. 

8 Fan status Indicate whether the fan speed is normal when the device is 
working. 

 Normal: The speed of each fan in the device is normal. 

 Abnormal: The speed of one or some fans in the device is 
abnormal, and the device needs troubleshooting. 

9 Settings Click to enter the device menu where you can perform the 
following device operations. 

 Network settings: Configure the device IP address. 

 Device information: Check the device’s chassis and card 
version, and fan status. 

 Advanced settings: Perform factory reset settings, firmware 
update, project file import and export, log export, and AC back 
settings for the device. 

 About us: Check the official website and technical support 
email address of the device manufacturer. 
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6.2.3 Network Settings 

 On the home screen, tap  located at the bottom right corner to enter the settings 
screen. 

 Select Network to enter the network settings screen. 

 Configure the device IP address information. 

 IP address settings 

 

The device supports both automatic (DHCP) and manual IP configuration. When the 
device is connected via router or switch, DHCP is recommended. The router or switch 
will automatically assign IP address to the device. When the network mode is set to 
Manual, you need to set IP Address, Subnet Mask and Gateway. 

 Note 

When manually configuring the IP address, the device IP address and the control 
computer IP address must be on the same network segment.  

 Tap Apply to complete the settings. 

6.2.4 Device Information 

On the Device screen, you can check the power supply status, card temperature and 
fan running status of the device.  
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 Device information 

 

Two ways to enter the Device screen: 

 On the home screen, tap  located at the bottom right corner to enter the 
settings screen. Then, tap Device on the left. 

 On the home screen, tap the icon in the status bar on the right to enter the 
corresponding screen under Device. 

− : Displays the voltage status of the connected power supply. Tap this 
icon to enter the Voltage screen under Device, where you can check the 
connection status of the three power supplies and whether the power 
connector voltage is normal. 

− : Displays the device card temperature. Tap this icon to enter the Card 
screen under Device, where you can check the card temperature and 
version. 

− : Displays whether the device fans are running normally. Tap this icon to 
enter the Fans screen under Device, where you can check the status of all 
the device fans. 

6.2.5 Advanced Settings 

In advanced settings, you can do the following operations: 

 Factory reset 

 Update firmware 

 Import and export project files 

 Export log files 

 Set the device status after AC power back 

On the home screen, tap  located at the bottom right corner to enter the settings 
screen. Then, tap Advanced to enter the advanced settings screen. 
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 Advanced settings 

 

Factory Reset 

This function is used to quickly clear the data saved in the device. All parameters will 
be restored to the default values. 

 Keep User Data: During factory reset, the network configuration, EDID files, 
gallery, device name and language settings will be kept, while other parameters 
will be restored to the default values.  

 Reset All: All device parameters will be restored to the default values. 

Update Firmware 

The Q8 supports firmware update via USB drive. To do that, save the update file in the 
root directory of the USB drive and then insert the drive into the USB port on the 
control card of the Q8. 

On the Advanced screen, tap Update to enter the firmware update screen and the 
system will automatically detect and read the update file in the USB drive. 
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 Firmware update 

 

Select the target update file, tap Update, and the system will automatically update the 
device. 

After the update is complete, the device will automatically restart. 

Import and Export Project Files 

The Q8 supports import and export of configured project information via USB drive, 
allowing you to quickly complete device configuration. 

 To export project files, insert the USB drive that is used to save the files into the 
USB port on the control card of the Q8. 

 To import project files, save the files in the root directory of the USB drive and 
then insert the drive into the USB port on the control card of the Q8. 

On the Advanced screen, tap Projects to enter the project file import and export 
screen. 
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 Importing and exporting project file 

 

 Importing project file: Tap Import File, and the system will automatically read the 
project files in the USB drive. After selecting the target file, tap OK, and the 
system will automatically import the file to the device. After the import is 
complete, the device will automatically restart. 

 Exporting project file: Tap Export File, and the system will automatically export 
the current configured project file to the selected USB drive. 

Export Logs 

The Q8 supports export of the device running logs via USB drive. When the device 
has an exception, the logs can help you quickly troubleshoot the problem. 

To export logs, insert the USB drive that is used to save the logs into the USB port on 
the control card of the Q8. 

On the Advanced screen, tap Logs to enter the log export screen. 
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 Exporting logs 

 

Tap Log Export to export the device logs to the selected USB drive.  

Set Device Status After AC Back 

Set whether the device automatically powers on after the power is supplied. 

 AC back 

 

 Power On: After the power is supplied, the device automatically powers on. 

 Power Off: After the power is supplied, the device remains in the power-off state. 
To power on the device, press the power button on the device front panel. 

 Last State: After the power is supplied, the device remains in the last state. 
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6.2.6 Language 

The Q8 supports both Chinese and English UI languages. You can change the 
language on the Language screen. 

6.2.7 About Us 

On the About Us screen, you can check the device system version and the device 
manufacturer related information. 
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7 Event Management Software PixelFlow 

About This Chapter 

This chapter provides a detailed description of each section of the event 
management software PixelFlow, as well as a step-by-step approach to configure the 
projects, devices, screens, layers, Multiviewer, presets and more. 

Overview 

 Software Installation and Connection 

 Project Management 

 Device Management  

 Screen Configuration 

 Layer Operation 

 MVR (Multiviewer) 

 Preset Management 

 Screen Maintenance 

 Software Settings 
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Software Installation and Connection 

7.1.1 Software Installation 

Prerequisites 

 The software package is obtained. 

 A computer meeting the following requirements is prepared: 

− Operating system: Windows 10 (64-bit) or later 

− CPU: Intel® Core™ i5 or later 

− RAM: 8GB or greater 

Installation Method 

Run the .exe file and follow the setup wizard to complete the installation. If a firewall 
prompt appears, choose to allow the installation. 

Installation Result 

After a successful installation, the PixelFlow software icon  is displayed on the 
desktop. Double-click this icon to open the PixelFlow software. 

7.1.2 Software Connection 

The PixelFlow software is installed on the control computer. The control computer 
can connect to the device in the following two ways: 

 Via Ethernet cable 

Connect the device and the control PC directly via Ethernet cable and set a static 
IP address for the device to let it and the control PC be on the same network 
segment. 

 Via LAN 

Connect the device and the control PC to the same LAN via a router and set the 
device to automatically obtain an IP address. 

 Notes 

 The device in this chapter refers to the P20, P10 or Q8 presentation switcher.  

 The software pictures given in this chapter are used for illustration purposes 
only. The actual user interface may vary slightly due to product enhancement. 
The content of the pictures can be slightly different from reality, such as the 
form and position of the software windows, input source images and more. 
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Project Management 

Create, edit and delete projects, and view project details. The project file (.uprj) can 
be exported by the current device, and then imported into other devices of the same 
model, so as to quickly apply the device parameters and resource files in the project 
file. 

7.2.1 Create New Projects 

Create a new project and add one or more devices. 

 Select Projects on the left side of the interface to show the project list. 

 Project list 

 

 Click New Project. 

 Create new projects 
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 Set the project name, select the devices to be included in this project, and click Add. 

 Note 

A device can be added to one project only.  

Related operations are as follows: 

 Remove: Withdraw the selected devices in Selected Device List to Device List. 

 Add All: Add all the devices in Device List to Selected Device List. 

 Remove All: Withdraw all the devices in Selected Device List to Device List. 

 After the settings, click OK. 

After a project is successfully created, you will enter the device configuration 
interface. 

 Note 

In the project list area, you can perform the following project-related operations: 

 Rename project: Hover the mouse over the desired project and click  that 
appears on the right side of the project name. 

 Enter project: Click Enter in the Action column. 

 Edit project: Click Edit in the Action column. 

 Delete project: Click Delete in the Action column. 

 View project details: Click Details in the Action column. 
 

7.2.2 Import Projects 

Import the local project files to the device. Please note that the device model must 
match with that in the project file. 

 Select Projects on the left side of the interface or go to Projects > Import. 

 In the dialog box that appears, select a project file and click OK. 

 In the displayed Import Project File box, select the desired parameters and click OK. 
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 Import project files 

 

7.2.3 Export Projects 

Export the device project files to your local computer. 

 Select Projects on the left side of the interface to show the project list. 

 Double-click the project name, or click Enter in the Action column to enter the device 
configuration interface. 

 From the menu bar, select Projects > Export. 

 In the displayed dialog box, select the desired parameters. 

 Export project files 

 

 Click Export. 

 In the displayed dialog box, select a file path and click Save. 
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Device Management 

7.3.1 Enter Device Configuration Page 

 Select Device on the left side of the interface to show the device list. 

 Device list 

 

 If the device is not logged in, please click Login, and then in the pop-up dialog box 
click Login directly while keep the default values of the user name and password 
unchanged. If the device is already logged in, please skip this step.  

 Device login 

 

 Click  to refresh the device list. 

 (Optional) Switch the display style of the device list as desired. 

 : Graphical view 
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View the device name, IP address and model. USED in the device lower right 
corner indicates that the device has been added to a project. 

 : List view 

View the device name, IP address, model, and the project the device belongs to. 

 Note 

Hover the mouse over the desired device and click  that appears on the right side 
of the device to rename the device.  

 Perform either of the following actions to enter the device configuration page. 

 In the graphic view mode , double-click the picture of the device front panel. 

 In the list view mode , click Enter in the Action column. 

7.3.2 Configure Device Properties 

Select the device on the left side of the device configuration interface, and then 
configure the device-related properties on the right pane. 

 Device properties (P20) 

 

Rename Device 

Change the device name. 

Prerequisites 

None 

Notes 

None 
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Interface Example (P20) 

 

Description 

Enter a name for the device in the text box next to Device Name. 

 Note 

In the device list on the left side of the interface, you can also right click the device 
name and select Rename from the context menu to change the device name as well.  

Configure IP Address 

Manually set a static IP address for the device or let the device to automatically 
obtain an IP address. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

Configure the following parameters and click Apply to make the settings take effect. 

Parameter Description 

Network Mode Select the IP configuration method. 

 Manual: Manually set a static IP address for the device. 

 DHCP: The device automatically obtains an IP address. 

IP Address The device IP address 

Subnet Mask The subnet mask of the IP address 
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Parameter Description 

Gateway The default gateway 

Configure Sync Source 

Enable the sync function and configure the sync source. 

Prerequisites 

Before enabling the Genlock sync function, make sure the sync signal has been 
connected to the Genlock connector of the device. 

Notes 

None 

Interface Example (P20) 

 

Description 

Parameter Description 

Sync To Turn off the sync function; or turn on the function and then 
select the sync source to be used. 

 Off: Disable the sync function. 

 Genlock: Sync with the frame rate of the accessed Genlock 
signal. 

 Input X: Sync with the frame rate of the selected input 
source.  

X indicates the serial number of the input source and the 
actual format shall prevail. 

When the function is enabled, the frame rate of the sync 
source will be displayed. 

Configure Output Mapping 

Turn on or turn off the output mapping function. If turned on, each output displays its 
slot number in the loading area of the screen. 

Prerequisites 

The device model is Q8. 
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Notes 

None 

Interface Example (Q8) 

 

Description 

Parameter Description 

Mapping Turn on or turn off the function. 

 : On 

 : Off 

 Note 

In the device list on the left side of the interface, you can also right click the device 
name and select Mapping from the context menu to enable or disable the mapping 
function as well.  

Configure HDR Format Conversion 

Turn on or turn off the HDR format conversion function. If turned on, you can set the 
HDR-related parameters for the input and output. 

Prerequisites 

The device model is the P20. 

Notes 

None 

Interface Example (P20) 

 

Description 

Parameter Description 

HDR Format 
Conversion 

Turn on or turn off the function.  

 : On 

 : Off 
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Switch Working Mode 

When the device supports dual working modes (Switcher and PGM Only), you can 
switch to either mode that satisfies your actual needs. 

Prerequisites 

The device model is the P20 and P10. 

Notes 

None 

Interface Example (P20) 

 

Description 

Select Switcher or PGM Only from the drop-down list. 

Configure Date and Time 

Configure the time zone, date and time of the device. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

Click Edit and the time parameters become editable. Set the time zone, date and time 
respectively, and then click Apply. 



Event Presentation Switching Solution User Manual 7 Event Management Software PixelFlow 

 

www.pixelhue.com 106 
 

Configure Input Source Backup 

Configure the backup relation between two sources. For two input sources with a hot 
backup relationship, when the primary source has no signal, it will automatically 
switch to the backup source. 

Prerequisites 

None 

Notes 

 The function is applicable when the capacities of the input connectors are the 
same. 

 After the function is enabled, the switching of the connector capacity and 
connector type are not supported. 

Interface Example (P20) 

 

Description 

 Set the Input Source Backup switch to . 

 Select or deselect Primary Source Preferred. 

 Click Add. 

 Select a primary source and a backup source respectively from two drop-down lists 
to establish a hot backup pair. 

The green color indicates the source is accessed normally and ready for use. 

To delete a hot backup pair, click  next to the pair. To delete all hot backup pairs, 
click Delete All. 

Reset to Factory Settings 

Reset the device data and settings to factory default values. 

Prerequisites 

None 

Notes 

 Please do this with great caution. 

 The reset action does not affect the device firmware version. 
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 Power-off is not allowed during the reset process. 

 The device will restart automatically after the reset is completed. 

Interface Example (P20) 

 

Description 

Select Keep user data or Reset all, and then click Apply. 

 Keep user data 

Retain the network parameters, project files, EDID files, gallery files and device 
language settings. 

 Reset all 

Retain the network parameters and project files. 

Shut Down or Restart Device 

Shut down the device, or restart the device. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

Click Restart or Shut Down, and then click Yes in the displayed dialog box. 

7.3.3 Configure Input Properties 

Click the target input connector on the graphical device rear panel (if you need to 
configure the card properties, please click the desired card on the rear panel), and 
then set the input-related properties in the property area on the right pane. 
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 Input properties (P20) 

 

Configure Card Properties 

Set the input connectors to be used, connector capacity (resource occupation) and 
deinterlacing function. 

Prerequisites 

 The connector capacity is available on the P20 and P10. 

 The deinterlacing function is available on the Q8. 

Notes 

If the connector is set to be NOT used: 

 The corresponding layers on the main screens and AUX screens will become 
empty layers. 

 Some connector properties will be restored to defaults, such as resolution and 
color parameters. 

If the connector capacity is switched on the P20 and P10: 

 The corresponding layers on the screens will become empty layers, and the DSK 
function will be turned off. 

 Some connector properties will be restored to defaults, such as resolution and 
color parameters. 
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Interface Example (Q8) 

 

Description 

 Switch the connector capacity. 

Select SL or 4K from the drop-down list. 

 Select the connectors to be used. 

The connector status descriptions are as follows: 

− : Selected 

− : Not selected 

 Set the deinterlacing function. 

Click the Deinterlace icon. 

− : On 

− : Off 

After the settings, click Apply. 

View Input Source Info 

View the basic properties of the input connector, change the input connector name, 
as well as enable or disable the HDCP function. 

Prerequisites 

 A fine signal is connected to the input connector. 

 HDCP function is applicable to the P20 and P10. 

Notes 

None 
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Interface Example (P20) 

 

Description 

On the Basic tab interface, perform the following actions as required:  

 Change connector name 

Enter a new connector name, and then click elsewhere in the interface to 
complete the connector name change. 

 Enable or disable HDCP 

Set the function switch to  (enabled) or  (disabled). 

Configure Override Parameters 

Configure the InfoFrame override parameters of the input source, so that the device 
can use it when doing some calculations. This action does not change the parameter 
values that come with the input source. 

Prerequisites 

The HDR-related parameter settings are applicable to the P20, and make sure you 
have turned on the HDR format conversion function in the device property 
configuration page before the settings. For specific operations, please refer to 7.3.2.5 
Configure HDR Format Conversion. 

Notes 

None 
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Interface Example (P20) 

 

Description 

On the Basic tab interface, configure the following parameters. 

Type Parameter Description 

General 
parameters 

Color/Sample The sampling format of the input 

Bit Depth The bit depth of the input, i.e., the binary digits to 
represent a single color 

Quantization 
Range 

The quantization range of the input 

HDR parameters Dynamic Range The HDR format of the input  

Color Gamut The color gamut standard of the input 

Select Follow Input and the device will read the attribute values that come with the 
input source. 

Configure EDID 

Configure the resolution and frame rate of the input. You can select the standard 
resolution provided by the device, customize a resolution, or set the advanced 
parameters. 

Prerequisites 

 The front-end device outputs the video source from the graphics card. 

 The input connector must be DP 1.2 or HDMI 2.0. 12G-SDI does not support this 
function. 

Notes 

It is recommended the advanced settings are carried out by the trained personnel 
only. 
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Interface Example (P20) 

 

Description 

On the EDID tab interface, configure the following parameters and click Apply after 
the settings. 

Parameter Sub-Parameter Description 

Standard Resolution The common (standard) resolution 

Frame Rate The common (standard) frame rate, i.e., the image 
frames every second (unit: Hz) 

Custom Resolution The number of horizontal pixels and vertical pixels of 
the image 

Config method: Select Custom from the drop-down 
list, and then set the width and height values 
respectively. 

Frame Rate The image frames every second (unit: Hz) 

Advanced H Total Total pixel count per line 

H Active The horizontal size in pixels of the active area 

H Front Porch The offset between the end of the active area and the 
beginning of the H sync 

H Sync The horizontal sync width in pixels (or between 
pixels) 
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Parameter Sub-Parameter Description 

H Polarity The polarity of the horizontal sync pulse 

V Total Total pixel count per column 

V Active The vertical size in pixels of the active area 

V Front Porch The offset in lines between the end of the active 
output area and the beginning of V sync 

V Sync The vertical sync width in rows (or between rows) 

V Polarity The polarity of the vertical sync pulse 

Frame Rate The image frames every second (unit: Hz) 

Import and Export EDID 

When compatibility problem occurs on an input connector, import an intact EDID file 
into the device; or export an EDID file from a device and provide the EDID file to other 
devices or input connector to solve the compatibility problem. 

Prerequisites 

The input connector must be DP 1.2 or HDMI 2.0. 12G-SDI does not support this 
function. 

Notes 

Each input connector supports importing one EDID file only and the EDID file must be 
less than 1 MB. 

Interface Example (P20) 

 

Description 

 EDID Import 

On the EDID tab interface, click EDID Import. In the dialog box that appears, 
select an EDID file and click Open. 

 EDID Export 

On the EDID tab interface, click EDID Export. In the dialog box that appears, 
select a path and click Save. 

 Note 

If you need to modify the content of an imported EDID file, just modify it and then re-
import it to overwrite the original one.  
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Configure Input Color 

Set the image quality parameters of the input connector, so that all video sources 
connected to it will have the same image quality. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

On the Effect tab interface, configure the following parameters. 

Parameter Description 

Contrast The ratio of the luminance of the brightest color to that of the 
darkest color 

Saturation The color purity of the image. The higher the value, the more vivid 
the color. 

Hue The relative degree of how bright or dark the input source image is 

Brightness The shading of lights in the image 

Configure DSK 

Achieve the luma keying or chroma keying effect on the input source. 

Prerequisites 

 The device model is Q8.  

If your device is the P20 and you want to achieve the DSK effect, please refer to 
7.5.3.14 Configure DSK to set the related parameters in the layer property area. 

 A fine signal is connected to the input connector. 
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Notes 

None 

Interface Example (Q8) 

 

Description 

On the DSK tab interface, configure the following parameters. 

Type Parameter Description 

Function 
switch 

DSK Turns on or turn off the function. 

 : On 

 : Off 

Description: 

 Luma key: Suitable for application scenarios where 
the brightness of the background is significantly 
smaller than that of the foreground. The result of 
luma key is that the background becomes 
transparent and the foreground is keyed out. 

 Chroma key: Suitable for application scenarios with 
a single background color, such as blue/green 
screen matting 

Luma key 
parameters 

Clip To distinguish between the foreground and 
background 

Gain The hue softness of the transition area  

The larger the value, the softer the transition. 

Foreground 
Color 

Turn on or turn off the function. 

 : On. After the function is turned on, the 
associated parameter Color can be used to adjust 
the keying effect. 

 : Off 

Color The RGB values of the foreground color 

Chroma key 
parameters 

Pick The RGB values of the pick point 

 Config method 1: Click Pick, and then click the 
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Type Parameter Description 

position to be picked in the input source image. 

 Config method 2: Set the coordinates of the pick 
point in the input source image. 

 Config method 3: Set the RGB values of 
Background Point. 

After the settings, click Apply. You can also adjust the 
following parameters to optimize the keying effect. 

Hue Ramp To distinguish between the foreground and 
background 

Hue Clip The hue range 

The larger the value, the larger the removal area. The 
maximum value is the current value of Hue Ramp. 

Saturation 
Clip 

To distinguish between the foreground and 
background 

Gain The hue softness of the transition area  

The larger the value, the softer the transition. 

Spill To remove the overflow from the foreground image 
edges and semi-transparent areas 

Shadow To remove the shadow areas 

Highlight To remove the highlight areas 

Edge Smooth Turn on or turn off the function. 

 : On 

 : Off 

7.3.4 Configure Output Properties 

Click the target output connector on the graphical device rear panel, and then set the 
output-related properties in the property area on the right pane. 
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 Output properties (P20) 

 

View Output Info 

View the basic output properties, and change the output connector name. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

On the Basic tab interface, enter a new connector name, and then click elsewhere in 
the interface to complete the connector name change. 
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Export EDID 

When the EDID compatibility of the input connector of the back-end device is good, 
the device can learn the EDID of the back-end device through the output connector 
and export the EDID to a local computer for possible future use. 

Prerequisites 

 The output connector is connected to the back-end device normally. 

 The output is a main output (not AUX output). 

Notes 

None 

Interface Example (P20) 

 

Description 

On the EDID tab interface, click EDID Export. In the dialog box that appears, select a 
path and click Save. 

Configure Output Color 

Configure the output color parameters. The ultimate output image quality is decided 
by the layer color, input color and output color settings. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 
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Description 

On the Effect tab interface, configure the following parameters. 

Parameter  Description 

Contrast The ratio of the luminance of the brightest color to that of the 
darkest color 

Brightness The shading of lights in the image 

Hue The relative degree of how bright or dark the input source image 
is 

Saturation The color purity of the image 

The higher the value, the more vivid the color. 

Configure Multiviewer 

Configure the connector mode and resolution of the Multiviewer connector. 

Prerequisites 

The device model is the Q8. 

Notes 

None 

Interface Example (Q8) 

 

Description 

Configure the following parameters and click Apply. 

Parameter  Description 

Connector Mode Configure the working mode of the Multiviewer connector. 

 Independent: Two Multiview connectors output their own 
monitoring images.  

 Copy: HDMI 2 copies the monitoring data on HDMI 1. 

Connector Resolution Select the desired connector resolution. 
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Screen Configuration 

7.4.1 Configure Screens 

Configure the layout of a main (not AUX) screen, as well as add and replace the 
output connectors. 

 Enter the device configuration page as described in 7.3.1 Enter Device Configuration 
Page. 

 Select the target device on the left, and then select Screen at the top of the page. 

 Screen configuration (P20) 

 

 If the device model is the Q8, click  to add screens; if the device model is the P20 
and P10, the number of screens is fixed and you can skip this step. 

For the Q8, if you need to delete a single screen, place the mouse on the screen name 

and click ; if you need to delete all screens, click . 

 Click the screen name to select a screen. 

 Click the layout style icon in the toolbar above the editing area, or customize the 
layout by setting the number of rows and columns. 

 Toolbar (P20) 

 

 Drag the output connector to the desired screen to complete the screen 
configuration. 
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To change an output, simply drag another output connector to the screen. 

7.4.2 Configure Screen Properties 

Click the desired screen, and then set the screen-related properties in the property 
area on the right pane. 

Rename Screens 

Change the screen name. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

On the Basic tab interface, enter a new screen name, and then click elsewhere in the 
interface to complete the screen name change. 

Configure Connector Position 

Configure the start position of the output connector. 

Prerequisites 

The device model is the Q8. 

Notes 

None 

Interface Example (P20) 
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Description 

On the Basic tab interface, configure the following parameters. 

Parameter  Description 

H Position The horizontal start position of the output connector 

V Position The vertical start position of the output connector 

Configure Test Patterns 

Test patterns are used to check the connection relation between the output 
connectors and the screen, and check whether the screen display is good. 

Prerequisites 

The screen is a main (not AUX) screen. 

Notes 

None 

Interface Example (P20) 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Test Pattern Turn on or turn off the function. 

 : On 

 : Off 

After the function is enabled, select the desired test pattern. 
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Parameter Description 

Brightness Sett the brightness of the test pattern. 

Spacing Level Set the spacing between different color areas. 

If a multi-color test pattern is selected, this parameter is 
displayed. 

Spacing (px) Set the spacing between the lines. 

If a grid test pattern is selected, this parameter is displayed. 

Grid Width Set the width of the grid lines. 

Speed Set the moving speed of the lines. 

Configure AOI 

When the output connector resolution is greater than the actual screen resolution, 
you can configure an unequal mosaic rather than changing the resolution of the 
output connector. 

Prerequisites 

The screen is a main (not AUX) screen. 

Notes 

None 

Interface Example (P20) 

 

Description 

Select the output connector on the canvas, and then configure the following 
parameters on the Basic tab interface. After the settings, click Apply. 
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Parameter Description 

X The horizontal offset relative to the starting position of the original 
connector 

Y The vertical offset relative to the starting position of the original 
connector 

Width The horizontal pixels 

Height The vertical pixels 

Configure Screen Color 

Configure the screen color parameters. 

Prerequisites 

None 

Notes 

None 

Interface Example (P20) 

 

Description 

On the Effect tab interface, configure the following parameters. 

Parameter Description 

Contrast The ratio of the luminance of the brightest color to that of the 
darkest color 

Brightness The shading of lights in the image 

Hue The relative degree of how bright or dark the input source image is 

Saturation The color purity of the image 

The higher the value, the more vivid the color. 



Event Presentation Switching Solution User Manual 7 Event Management Software PixelFlow 

 

www.pixelhue.com 125 
 

Configure Timing 

Configure the resolution and frame rate of the output. You can select the standard 
resolution provided by the device, customize a resolution, or set the advanced 
parameters. 

Prerequisites 

The EDID of the back-end device is obtained. 

Notes 

 It is recommended the advanced settings are carried out by the trained 
personnel only. 

 After the output resolution is changed, the AOI parameters associated with the 
connector will be automatically reset. 

Interface Example (P20) 

 

 

Description 

On the Output tab interface, configure the following parameters and click Apply. 

Parameter Sub-Parameter Description 

Standard Resolution The common (standard) resolution 

Frame Rate The common (standard) frame rate, i.e., the image 
frames every second (unit: Hz) 
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Parameter Sub-Parameter Description 

Custom Resolution The number of horizontal pixels and vertical pixels of 
the image 

Config method: Select Custom from the drop-down list, 
and then set the width and height values respectively. 

Frame Rate The image frames every second (unit: Hz) 

Advanced H Total Total pixel count per line 

H Active The horizontal size in pixels of the active area 

H Front Porch The offset between the end of the active area and the 
beginning of the H sync 

H Sync The horizontal sync width in pixels  (or between 
pixels) 

H Polarity The polarity of the horizontal sync pulse 

V Total Total pixel count per column 

V Active The vertical size in pixels of the active area 

V Front Porch The offset in lines between the end of the active output 
area and the beginning of V sync 

V Sync The vertical sync width in rows (or between rows) 

V Polarity The polarity of the vertical sync pulse 

Frame Rate The image frames every second (unit: Hz) 

Configure Output Parameters 

Configure the output-related parameters. 

Prerequisites 

Before setting the HDR format conversion related parameters here, make sure your 
device is the P20 and you have turned on the HDR format conversion function. For 
specific operations, please refer to 7.3.2.5 Configure HDR Format Conversion. 

Notes 

None 
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Interface Example (P20) 

 

Description 

On the Output tab interface, configure the following parameters. 

Type Parameter Description 

General 
parameters 

Color/Sample The sampling format of the output 

Bit Depth The bit depth of the output, i.e., the binary digits 
to represent a single color 

HDR parameters Dynamic Range The dynamic range format of the output 

Color Gamut The color gamut standard of the output 

Gamma The Gamma value 

Configure LCD Bezel Compensation 

Configure the edge compensation parameters for LCD splicing screens to make the 
image visually integrated. 

Prerequisites 

The device model is the Q8. 

Notes 

None 

Interface Example (Q8) 

 

Description 

On the Advanced tab interface, configure the following parameters. 
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Parameter Description 

LCD Bezel 
Compensation 

Turn on or turn off the function. 

 : On 

 : Off 

Horizontal Spacing The total width of the borders at the horizontal joints of the 
screens 

Vertical Spacing The total width of the borders at the vertical joints of the 
screens 

Layer Operation 

7.5.1 Add Layers 

Add the layers to the screen. Multiple layers can be added to a main screen, but only 
one layer can be added to an AUX screen. The AUX screen layer fills the screen, with 
its size and position unadjustable. 

 Enter the device configuration page as described in 7.3.1 Enter Device Configuration 
Page. 

 Select the target device on the left, and then select Programming at the top of the 
page. 

 Programming (P20) 

 

 Click a screen name to select the screen, or click Multiple select to select multiple 
screens. 

 Add the layers to the screens. 

 Main screen: Drag an input source to the screen. 
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 AUX screen: Drag an input source in the input list or a PGM in the screen list to 
the AUX screen. 

 Perform the following layer operations as required. 

 Toolbar 

 

 Lock or unlock PGM 

In the lower left corner of the PGM area, click  to lock PGM, and click  to 
unlock PGM. 

 Capture PGM 

In the lower left corner of the PGM area, click  to start capturing. In the 
displayed dialog box, name the captured image and click Save. If you need to 
redo the capturing again, click Recapture. 

 Freeze layer 

Select a layer. Click  to freeze or unfreeze the layer. 

 Lock or unlock layer 

Select a layer. Click  to lock the layer, and click  to unlock the layer. 

 Maximize layer 

Select a layer, and then click  to maximize the display of the layer according 
to the output connectors it crosses. 

 Delete layer 

Select a layer, and then click . 

 Set PGM FTB 

Click FTB.  

− Blue: The function is turned on. 

− Gray: The function is turned off. 

 Freeze PGM 

Click FRZ.  

− Blue: The function is turned on. 

− Gray: The function is turned off. 

 Match PGM 

Click Match PGM to make the layers on PVW consistent with that on PGM. 

 PVW to PGM 

Select Swap, and the layers on PVW and PGM will be exchanged when sending 
PVW to PGM. 

Deselect Swap, and PGM will copy the layers on PVW when sending PVW to 
PGM.  

There are three methods for sending PVW to PGM: 

− Cut: Send the PVW layers to PGM without any transition effect. 
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− Take: Send the PVW layers to PGM with a time-specified transition effect. 

− T-Bar: Send the layers on PVW to PGM with a transition effect, and the 
transition duration depends on the time duration you push the T-Bar. 

 Set transition effect 

Select the desired effect from the drop-down list and set the transition duration. 

7.5.2 Manage Gallery 

Select the Gallery tab and do the following in the BKG or LOGO area as required. 

Import Pictures (.png/.bmp/.jpg/.jpeg) 

Click . Select the desired pictures in the displayed dialog box and then click Open. 

Export Pictures 

Click Edit and then click . Select a file path and click Save in the displayed dialog 
box. 

Delete Pictures 

Click Edit. Select the pictures to be deleted, and then click . In the displayed dialog 
box, click Yes. 

7.5.3 Configure Layer Properties 

Select the desired layer, and then set the layer-related properties in the property area 
on the right pane. 

Configure Basic Properties 

Configure the layer name, flipping, aspect ratio, as well as position and size. 

Prerequisites 

None 

Notes 

Only one layer can be added to an AUX screen. The AUX screen layer fills the screen, 
with its size and position unadjustable. 
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Interface Example (P20) 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Name The layer name 

Flip The layer flipping mode 

The supported options include None, Flip Horizontally, Flip 
Vertically, Flip Horizontally and Vertically. 

Aspect Ratio The ratio of the layer's width to its height 

After the aspect ratio is changed, the height of the layer remains 
unchanged, and the device automatically calculates its width. 

X The horizontal starting position of the layer on the main screen  

The coordinates of the first pixel in the upper left corner of the 
main screen are (0,0). 

Y The vertical starting position of the layer on the main screen  

The coordinates of the first pixel in the upper left corner of the 
main screen are (0,0). 

Width The horizontal size of the layer 

Height The vertical size of the layer 

Configure Layer Borders 

Configure the border style of a layer. 

Prerequisites 

The layer is a regular (not AUX) layer. 
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Notes 

If the layer mask function is turned on, the border function is turned off. 

Interface Example (P20) 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Border Turn on or turn off the function. 

 : On 

 : Off 

Type The layer border type 

Width The width of the layer left or right border 

Height The height of the top or bottom border 

Color The layer border color 

When the border function is set to , this parameter is available. 

Configure Layer Mask 

Configure the mask-related parameters. The masked area becomes transparent and 
the layer size remains the same. 

Prerequisites 

The layer is a regular (not AUX) layer. 

Notes 

If the layer mask function is turned on, the border function is turned off. 



Event Presentation Switching Solution User Manual 7 Event Management Software PixelFlow 

 

www.pixelhue.com 133 
 

Interface Example (P20) 

 

Description 

On the Basic tab interface, configure the following parameters. 

Parameter Description 

Mask Turn on or turn off the function. 

 : On 

 : Off 

Mask Top Set the masked area height from the top edge of the layer.  

Mask Bottom Set the masked area height from the bottom edge of the layer.  

Mask Left Set the masked area width from the left edge of the layer. 

Mask Right Set the masked area width from the right edge of the layer. 

Configure Layer Color 

Configure the layer color parameters. 

Prerequisites 

The layers is a regular (not AUX) layer. 

Notes 

None 
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Interface Example (P20) 

 

Description 

On the Effect tab interface, configure the following parameters. 

Parameter Description 

Contrast The ratio of the luminance of the brightest color to that of the 
darkest color 

Brightness The shading of lights in the image 

Hue The relative degree of how bright or dark the input source image is 

Saturation The color purity of the image 

The higher the value, the more vivid the color. 

Opacity The layer opacity 

Monochrome Turn on or turn off the function. 

 : On, and the layer image is show in black and white. 

 : Off 

Invert Colors Turn on or turn off the function. 

 : On, and the layer image is show in the complementary 
color of its original color. 

 : Off 

Crop Input Sources 

When there are black borders or other redundant info in the input source image, the 
required picture can be retained through the cropping the input source, so as to 
improve the screen utilization. 

Prerequisites 

 The device model is the P20 and P10. 
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 The layer is a regular (not AUX) layer, and the layer input source is a good one. 

Notes 

The status and capacity of the cropped input source are consistent with that of the 
original one. 

Interface Example (P20) 

 

Description 

On the Advanced tab interface, configure the following parameters. 

Parameter Description 

Layer Source Crop Turn on or turn off the function. 

 : On 

 : Off 

X The horizontal initial coordinate of the cropped part upon the 
current input source 

Y The vertical initial coordinate of the cropped part upon the 
current input source 

Width The horizontal pixels of the cropped part 

Height The vertical pixels of the cropped part 

Configure DSK 

Achieve the luma keying or chroma keying effect on the input source. 

Prerequisites 

 The device model is the P20. If your device is the Q8 and you want to achieve the 
DSK effect, please refer to 7.3.3.7 Configure DSK to set the related parameters in 
the input property area. 

 The layers is a regular (not AUX) layer, and the layer input source is a good one. 

Notes 

After the DSK function is enabled, the layer capacity will automatically change to 4K. 
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Interface Example (P20) 

 

Description 

On the DSK tab interface, configure the following parameters. 

Type Parameter Description 

Function 
switch 

DSK Turns on or turn off the function. 

 : On 

 : Off 

Description: 

 Luma key: Suitable for application scenarios 
where the brightness of the background is 
significantly smaller than that of the 
foreground. The result of luma key is that the 
background becomes transparent and the 
foreground is keyed out. 

 Chroma key: Suitable for application scenarios 
with a single background color, such as 
blue/green screen matting. 

Luma key 
parameters 

Clip To distinguish between the foreground and 
background 

Gain The hue softness of the transition area  

The larger the value, the softer the transition. 

Foreground 
Color 

Turn on or turn off the function. 

 : On. After the function is turned on, the 
associated parameter Color can be used to 
adjust the keying effect. 

 : Off 

Color The RGB values of the foreground color 

Chroma key 
parameters 

Pick The RGB values of the pick point color 

 Config method 1: Click Pick, and then click the 
position to be picked in the input source 
image. 

 Config method 2: Set the coordinates of the 
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Type Parameter Description 

pick point in the input source image. 

 Config method 3: Set the RGB values of 
Background Point. 

After the settings, click Apply. You can also adjust 
the following parameters to optimize the keying 
effect. 

Hue Ramp To distinguish between the foreground and 
background 

Hue Clip The hue range 

The larger the value, the larger the removal area. 
The maximum value is the current value of Hue 
Ramp. 

Saturation Clip To distinguish between the foreground and 
background 

Gain The hue softness of the transition area  

The larger the value, the softer the transition. 

Spill To remove the overflow from the foreground 
image edges and semi-transparent areas 

Shadow To remove the shadow areas 

Highlight To remove the highlight areas 

Edge Smooth Turn on or turn off the function. 

 : On 

 : Off 

MVR (Multiviewer) 

7.6.1 Configure MVR Layout 

Configure the layout of the MVR windows. When the bandwidth of the input source 
exceeds the limit, the corresponding MVR image is black. 

 Enter the device configuration page as described in 7.3.1 Enter Device Configuration 
Page. 

 Select the target device on the left, and then select Multiviewer at the top of the 
page. 
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 MVR management (Q8) 

 

 Select a layout style. When the device model is the Q8, you can also click  to 
customize the number of rows and columns of the windows. 

 If the device model is the Q8, you can drag the input in the input list or drag PVW and 
PGM in the screen list to the MVR window. If the device model is the P20 and P10, 
please skip this step. 

To replace a signal of a specified window, simply drag another signal to the window. 
After a signal is selected, the following operations can be performed: 

 Delete signal: Click  to delete the signal of the window. 

 Maximize signal image: Click  to maximize the signal image according to the 
windows it crosses. 

To delete all signals, click . 

7.6.2 Configure MVR Properties 

Configure the position, UMD and borders of the MVR window. 

Prerequisites 

The device model is the Q8. 

Notes 

None 



Event Presentation Switching Solution User Manual 7 Event Management Software PixelFlow 

 

www.pixelhue.com 139 
 

Interface Example (Q8) 

 

Description 

Select an added MVR signal, and then set the related properties in the property area 
on the right pane. 

Type Parameter Description 

Window position X The X coordinate of the window on the MVR 
screen 

Y The Y coordinate of the window on the MVR 
screen 

Width The horizontal pixels of the window 

Height The vertical pixels of the window 

UMD UMD Turn on or turn off the function. 

 : On 

 : Off 

Color The color of the UMD text 

Border Width The width of the layer left or right border 

Height The height of the top or bottom border 

Color The layer border color 
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Preset Management 

Enter the device configuration page as described in 7.3.1 Enter Device Configuration 
Page. Select the target device on the left, and then select Screen Preset at the top of 
the page. 

 Preset management (P20) 

 

Save Presets 

Click a screen name to select the screen, or click Multiple select to select multiple 
screens. Perform the following actions as required. 

 Q8 

Click Save from PGM or Save from PVW. 

 P20 and P10 

Different working mode requires different actions:  

− Switcher: Click Save from PGM or Save from PVW. 

− PGM Only: Click Save Preset. 

Load Presets 

In the preset list, click the preset you want to load. 

 Q8: 

The preset is loaded to PVM. 

 P20 and P10 

− Switcher: The preset is loaded to PVM. 

− PGM Only: The preset is loaded to PGM. 
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Rename Presets 

Hover the mouse over the desired preset and click  that appears. Enter a new 
name and then click elsewhere to make the change take effect. 

Delete Single Preset 

Hover the mouse over the desired preset and click  that appears. In the displayed 
dialog box, click Yes. 

Delete All Presets 

Click Edit, select Select All, and click . In the displayed dialog box, click Yes. 

Screen Maintenance 

7.8.1 Device Maintenance 

In the main menu, select Maintain. Select the Device tab and the target devices, and 
then do the following as required. 

 Device maintenance 

 

Update 

 Note 

During the update process, power-off and all operations are NOT allowed. 
 

 Click Update.  

 In the pop-up dialog box, select the update file (.img) and click OK. 

 Click the Update button. 

 In the pop-up dialog box, click Yes and wait until the update completes automatically. 
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 After the update completes, click OK. 

Restart 

Click Restart. In the displayed dialog box, click Yes to restart the device. 

Factory Reset 

 Notes 

 Please do this with great caution. 

 The reset action does not affect the device firmware version. 

 Power-off is not allowed during the reset process. 

 The device will restart automatically after the reset is completed. 
 

Click Factory Reset. In the pop-up dialog box, select Keep user data or Reset all, and 
then click OK. 

 Keep user data 

Retain the network parameters, project files, EDID files, gallery files and device 
language settings. 

 Reset all 

Retain the network parameters and project files. 

 Factory reset 

 

Export Logs 

Click Export Log. In the dialog box that appears, select a path and click Save to save 
the device logs to local computer. 

7.8.2 Device Diagnostics 

In the main menu, select Maintain. Select the Diagnostics tab, select a device from 
the drop-down list, and click Diagnostics. 
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 Device diagnostics 

 

Software Settings 

7.9.1 Switch UI Language 

In the main menu, go to Settings > Language to switch the UI language. 

7.9.2 Configure Input View 

In the main menu, go to Settings > Input View. 

 √: The function is enabled, and the input source will have a live image in the 
software interface. 

 No mark: The function is disabled. 

7.9.3 Export Software Logs 

In the main menu, go to Settings > Export Software Logs. In the dialog box that 
appears, select a path and click Save to save the software logs to local computer. 

7.9.4 View Software Info 

In the main menu, go to Help > About Us to view the software-related info. 
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8 U5/U5 Pro Event Controllers 

About This Chapter 

This chapter introduces you to the U5/U5 Pro event controller. 

Overview 

 Introduction 

 Device Operations 
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Introduction 

The U series event controllers are equipped with two touchscreens, a main 
touchscreen and a smart touchscreen. On the main touchscreen, you can do various 
intuitive and free configurations for the seamless switchers, such as configurations 
of layers, layer position, input sources, output resolutions, input keying, layer borders, 
input crop and presets.  

The 8'' smart touchscreen displays still images, timecode, switcher and event 
controller status, and a Multiviewer image (Multiviewer 1, Multiviewer 2, or HDMI 1.3), 
and can be customized as a virtual MIDI keyboard. 

The U series event controllers include the following two models: 

 U5 event controller 

 U5 Pro event controller 

Hardware Introduction 

8.2.1 2.2.1 Front Panel 

U5 Front Panel 

 U5 front panel 

 

1. Main touchscreen 7. Function control area 

2. Screen buttons 8. Switching control area 

3. Layer buttons 9. T-Bar 

4. Input buttons 10. Power button 

5. Preset buttons 11. MIDI module area 

6. Smart touchscreen  

 Note 

The U5 LCD screen can be folded and lock at any angle between 45° and 125°.  
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U5 Pro Front Panel 

 U5 Pro front panel 

 

1. Main touchscreen 9. Smart touchscreen 

2. Device buttons 10. Number buttons 

3. Screen buttons 11. Switching control area 

4. Input buttons 12. MIDI module area 

5. Layer buttons 13. Power button 

6. Preset buttons 14. T-Bar 

7. Function control area 15. Keyboard 

8. Camera and timecode control area 16 Drawers 
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8.2.2 Rear Panel 

U5 Rear Panel 

 U5 rear panel 

 

1. 2x USB 3.0 5. 2x HDMI 2.0+1x HDMI 1.3 connectors 

2. Timecode module connector 

(optional module) 

6. 4x USB 2.0 ports 

3. Gooseneck lamp connector 7. USB (type-B) 

4. 2x ETHERNET ports 8. 1x Power module 

U5 Pro Rear Panel 

 U5 Pro Rear Panel 

 



Event Presentation Switching Solution User Manual 8 U5/U5 Pro Event Controllers 

 

www.pixelhue.com 148 
 

1. 2x USB 3.0 5. 2x HDMI 2.0+1x HDMI 1.3 connectors 

2. Gooseneck lamp connector 6. USB (type-B) 

3. Timecode module connector 7. 4x USB 2.0 ports 

4. 2x ETHERNET ports 8. 2x Power modules 

Connector Description 

No. Area Connector Qty Function 

1 USB USB 3.0 2 2x USB 3.0 on the right side of U5 

Connect to the mouse, keyboard, 
USB drive, etc. 

2 Gooseneck lamp 
connector 

- 1 Connect the gooseneck lamp. 

3 Timecode 
module 

LTC 3-pin XLR 
connector 

3 1x LTC IN, 2x LTC OUT 

 Connect to the external LTC-
format timecode input device. 

 LTC timecode output 

 MTC 5-pin XLR 
connector 

3 1x MTC IN, 1x MTC OUT, 1x USB 
(type-B) 

 MTC IN: Connect to the external 
MTC-format timecode input 
device. 

 MTC OUT: MTC timecode output 

 USB DEVICE: Support input and 
output of MTC timecodes from 
USB MIDI device 

4 ETHERNET Neutrik 
Ethernet ports 

2 2x Neutrik Gigabit Ethernet ports 

 Connect to the Ethernet control 
port of the backend control 
device. 

 Support mutual backup mode. 
The two Ethernet ports use the 
same IP address. 

 Support independent mode. The 
two Ethernet ports use two IP 
addresses. 

 Support transmission of the input 
view information. 

5 MULTIVIEWER HDMI 2.0 2  Generally connect to the MVR 
connector of the seamless 
switcher to view the output 
monitoring. 

 Up to 4K×2K@60Hz 
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HDMI HDMI 1.3 1  Generally connect to the output 
connector of the media server to 
display its user interface. 

 Up to 2K×1K@60Hz 

6 USB USB 2.0 4 Connect to the mouse, keyboard, 
USB drive, etc. 

7 MIDI / KVM USB (type-B) 1  KVM: Connect to a PC or media 
server via USB cable for KVM 
control. 

 MIDI: Connect to the MIDI control 
device for MIDI command output. 

 KVM and MIDI can be turned on 
at the same time. 

8 Power module 

- 

- 1 
or 
2 

 Power connector specifications: 
100-240V~, 6A, 50/60Hz 

 The U5 has one power module. 

 The U5 Pro has two power 
modules, one primary and one 
backup. 

Device Operations 

8.3.1 Basic Operations 

 Press: Press the button and release it within 3 seconds. 

 Hold down: Press and hold the button for 3 seconds or longer. 

 Click/Tap: Click or tap the menu once on the screen. 

 Double click/tap: Click or tap the same area twice quickly. 

 Combination of buttons: Hold down  or  to activate combination 
function and then press another function button to trigger the corresponding 
function. 

 Pinch in or stretch out: Place two fingers on the touchscreen and pinch in or 
stretch out. This operation is only to zoom in or out pictures on the smart 
touchscreen. 

8.3.2 Startup and Shutdown 

Prerequisites 

A power supply is connected and the power is supplied normally. 

Startup 

Press the  button in the upper right corner of the panel, and the system will 
automatically start up. After startup, the main touchscreen displays the home screen. 
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Shutdown 

Power off the event controller through the following methods: 

 Press the  button in the upper right corner of the panel, select OK in the pop-
up dialog box on the main touchscreen, and the system will shut down. 

 During the startup process, hold down the  button to force shutdown. 

 On the main touchscreen, choose Settings > Event Controller at the top and 
select the Other tab on the displayed page. In the Event Controller Power area, 
click Shut Down, and the device will automatically shut down. 

Restart Event Controller 

On the main touchscreen, choose Settings > Event Controller at the top and select 
the Other tab on the displayed page. In the Event Controller Power area, click Restart, 
and the device will automatically restart. 

 Note 

During startup or shutdown, the PIXELHUE logo is displayed on the home screen.  
 

8.3.3 Main Touchscreen 

The U5 has a 21.5’’ multi-touch main touchscreen with a resolution of 1920×1080. 

The U5 Pro has a 43.8’’ multi-touch main touchscreen with a resolution of 
1920×1080. 

On the main touchscreen, the built-in software user interface is displayed for you to 
do a lot of operations, such as adding devices, configuring screens, configuring 
inputs and outputs, configuring gallery, adding and deleting layers, configuring 
presets, configuring Multiviewer, importing and exporting project files, configuring 
the smart touchscreen, configuring the event controller skin, language and light, and 
much more. 

The main touchscreen supports the click, double-click, tap and double tap operations 
via the connected mouse or your finger. 

8.3.4 Device Buttons 

The U5 does not support switching between connected devices through buttons, 
while the U5 Pro supports switching between up to 16 connected seamless 
switchers through buttons. However, the buttons do not page-turning. 

When only one device is connected to the U5 Pro, the buttons in its device area will 
be automatically used as screen buttons. 
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 Device buttons 

 

Operations and status description of the 16 Device buttons: 

 The LCD button displays the device name. Pressing the button switches to the 
device corresponding to the button name for you to control that device. 

 White: A device is bonded to this button but not selected. 

 Green: A device is bonded to this button and is being operated. 

 Yellow: A device is bonded to this button, but the device is offline. 

 Blank button: No device is bonded to this button. 

8.3.5 Screen Buttons 

Pressing a screen button selects the corresponding screen, and the PVW page of 
that screen will be displayed on the main touchscreen. 

The screen name displayed in the screen button can be modified through the screen 
editing page.  

The screen quantity and screen name depend on the selected device connected to 
the event controller. 

 Screen buttons 

 

Screen Button Status 

The screen buttons have the following statuses: 

 Green: Screens are added to this button and being operated. 

 Yellow: Screens are added to this button but not selected. 

 Blank: No screens are added to this button. 
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Screen Button Operations 

 Press the screen button (yellow) bound with screens to select this screen. After 
the screen is selected, the screen button turns green, and the corresponding 
screen in the main touchscreen enters the PVW activated status. 

 Press different screen buttons consecutively to select multiple screens. 

 Holding down the selected screen cancels screen selection. The button will turn 
yellow, and the screen corresponding to the button will become unselected in 
the main touchscreen. 

 Pressing the button with no screens bound (blank button) quickly creates a 
screen. For that created screen, the system uses an unused and top-ranked 
output connector to add a screen. If there is no unused output connector, an 
empty screen will be created. 

Screen Page Up/Down 

If there are too many screens, they will be displayed on different screen pages on the 
screen buttons. The first page is displayed by default and the page jumping operation 
is performed in the following method. 

 Page Down: Press  to jump to the next page. For example, when the page 

button displays Page 1 currently, press  to jump to the screens displayed in 
Page 2. 

 Page Up: Button combination should be used. 

− U5: Press  while holding down the control button  in the control area 
to jump to the previous page. For example, when the page button displays 

Page 2 currently, use the combination of  and  buttons to jump to 
the screens displayed in Page 1. 

− U5: Press  while holding down the control button  in the control 
area to jump to the previous page. For example, when the page button 

displays Page 2 currently, use the combination of  and  buttons 
to jump to the screens displayed in Page 1. 

8.3.6 Input Source Buttons 

Press an input source button to select an input source for the layer. 

When a layer is selected, press an input source button to switch the layer input 
source. 

The U5 Pro has 30 input buttons and 2 page turning buttons. 

The U5 has 15 screen buttons and 1 page turning button. To jump to the previous 

page, use the combination of  and  buttons. 
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 Input source buttons 

 

The input source page turning button supports cyclic page turning. 

All the input sources are bound to the input buttons by default. When the input source 
changes, the button name will be automatically updated. 

The status of input source buttons are described as follows: 

 Green: The input source is being used by the selected layer. 

 Yellow: The input source corresponding to the button has signal but it is not 
used by the layer. 

 Red: The input source corresponding to the button has signal but it is used by 
the layer. 

 Orange: The input source corresponding to the button exceeds the connector's 
load capacity. 

 White: The input source corresponding to the button has no signal. 

 Blank button: The button does not have corresponding input source. 

8.3.7 Layer Buttons 

Pressing a layer button selects the corresponding layer and the PVW page of the 
screen corresponding to that layer will be displayed on the main touchscreen with 
that layer in the selected status. 

The layer name displayed in the layer button can be modified on the layer editing 
page. 

 The U5 Pro has 34 layer buttons and 2 page turning buttons. 

 The U5 has 15 layer buttons and 1 page turning button. To jump to the previous 

page, use the combination of  and  buttons. 

 Layer buttons 
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Layer Button Status 

 Green: The layer is selected. 

 Yellow: The layer is added but not selected. 

 Blank button: The button does not have corresponding layer. 

Layer Button Operations 

 Pressing the layer button (yellow) bound with layer selects this layer. After the 
layer is selected, the layer button turns green. On the main touchscreen, the PVW 
area of the screen where the layer belongs to enters the activated status and the 
corresponding layer is selected. 

 Pressing the button with no layers bound (blank button) quickly creates a layer. 
The system uses an unused and top-ranked source with signal as the source for 
that created layer. 

The default source used by the system is the one connected to the input 
connector that has the smallest number on the input card with the smallest 
number as well. 

8.3.8 Preset Buttons 

Pressing the preset button loads a saved preset to the screen PVW area. 

The preset name displayed in the preset button can be modified on the preset list 
page. 

 The U5 Pro has 34 preset buttons and 2 page turning buttons. 

 The U5 has 15 preset buttons and 1 page turning button. To jump to the previous 

page, use the combination of  and  buttons. 

 Preset buttons 

 

Preset Button Status 

 Green: The preset has been loaded to the screen PVW. 

 Yellow: The preset is saved but not loaded. 

 Red: The preset has been loaded to the screen PGM. 
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 Blue: This button is bound with the program of the media server. Pressing this 
button switches the program of the media server. 

 Purple: This button is bound with a preset and the program of the media server. 
Press this button to switch the program of the media server and switch the 
preset of the seamless switcher. 

 Blank button: The button does not have corresponding preset or program. 

8.3.9 Function Control Area 

 Function control area of U5 Pro 

 

 FTB: Make the output image fade to black. 

 FRZ: Freeze the current frame of the output image. 

 MATCH PGM: Press to synchronize all layer information in PGM to PVW. 

 PGM EDIT: Enable or disable the PGM editing function. After it is enabled, 
the layers in the current screen PGM can be edited. 

  / : Control button, which can be used together with another button. 
Press and hold this key, and then press another function button to realize a 

specific function. For example, press  while holding down  on the U5 Pro 
to jump to the previous page. 

 : MVR button for checking the Multiviewer image on the right side of the 
main touchscreen from the MULTIVIEWER and HDMI IN connectors on the rear 
panel. If you press it consecutively, the Multiviewer image will be switched with 
the order of MULTIVIEWER (HDMI 1) > MULTIVIEWER (HDMI 2) > HDMI I 

 : MEDIA button. When the HDMI IN connector is connected to the media 
server, its user interface will be displayed on the main touchscreen. If its user 
interface is displayed by pressing the MVR button, pressing the MEDIA button 
enables KVM control. 

 : Press to stretch the selected layer to fill the screen area(s) in which the 
selected layer is located before it is stretched.  

 : Press to enter the DSK page for you to do chroma key and luma key 
operations on the input source. 
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 : Press to bring the selected layer to front. 

 : Press to send the selected layer to back. 

 : Press to copy the selected layer. 

 : Press to flip the selected layer 

 : Hold down to lock the T-Bar. After it is locked and then pushed, the layer 
will not be switched. 

 : Hold down to lock the front panel and main touchscreen of the event 
controller. After locked, they cannot be used. 

 : In the U5 event controller, press this button to turn the page of the two rows 
of buttons on the left of this button. 

 Blank button: Reserved button for custom functions. 

8.3.10 Camera and Timecode Control Area 

The U5 Pro allows for adjusting the PTZ camera position and the timecode output. 

 

 : Save to button. Press to activate the save to function and the button 
flashes yellow. Then, press a preset button, and the current layer or program will 
be saved to the selected preset. 

 : Delete button. Press to activate the delete function and the button 
flashes yellow. Then, press a preset, layer or screen button, and the selected 
preset, layer or screen will be deleted. 

 : Timecode module control buttons 
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 PTZ camera adjustment buttons: 

− : Save the PTZ position after adjustment as a pattern for quick PTZ 
switching in the future. Press the button to activate it and it flashes yellow. 
Then, press Pattern 1 or Pattern 2 to save the PTZ camera positions in the 
two buttons. 

−  /  /  / : Adjust the PTZ camera shooting angle up, 
down, left and right. 

−  / : The saved PTZ camera positions. Press these buttons to 
apply the position to quickly adjust the PTZ camera. 

8.3.11 Smart Touchscreen 

 Smart touchscreen home 
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Import Still Images 

 Save the pictures to be imported into the smart touchscreen to the USB drive. 

 Insert the USB drive to the USB port on the side panel of the event controller. 

 On the main touchscreen, choose Settings > Event Controller, and select the Smart 
Screen tab to enter the tab page. 

 In the Still Images area, click  to add a pictures. 

 Select the inserted USB drive in the pop-up dialog box, select the necessary picture 
files, and click Open to import the selected pictures to the smart touchscreen. 

Up to 8 pictures in png, jpeg, jpg, and bmp formats can be imported into the smart 
touchscreen. 

View Images on Smart Touchscreen 

On the smart touchscreen, click Still Images to enter the subpage. 

 Still images are displayed in full screen mode on the smart touchscreen by 
default. 

 Swipe left or right to view the next or previous image. The images will cycle in a 
continuous loop as long as you keep swapping.  

 After you turn on slideshow function, the images will automatically cycle in a 
continuous loop as long as the slideshow function is turned on.  

 Pinch with two fingers to zoom in or out the still images. 

View Timecode 

On the smart touchscreen, click Timecodes and view the timecode information of 
output. 

 Timecode displayed 
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There are two ways to and configure timecode:  

 On the main touchscreen, choose Settings > Event Controller, select the Smart 
Screen tab to enter the tab page, and configure the timecode display format and 
display information. 

 In the “timecode control area” on the U5 Pro panel, press the corresponding 
button to change the timecode format, enable or reset timecode. 

Check Event Controller Running Status 

On the home of smart touchscreen, click Health to enter the subpage where you can 
check the following information: 

 CPU, RAM, motherboard, and disk running status 

 Power supply and HDMI connector connection status 

 Transmission rate of the Ethernet ports 

 Event controller health 

 

View Multiviewer Images 

On the home of smart touchscreen, click Multiviewer to enter the Multiviewer (MVR) 
page. 
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 Video page 

 

The following requirements must be met to view Multiviewer images. 

 The HDMI 2.0 connector in the MULTIVIEWER area on the rear panel of the event 
controller has been connected to the Multiviewer connector of the seamless 
switcher. 

 The Multiviewer configuration is completed on the main touchscreen. 

 The software control output connector of the media server has been connected 
to the HDMI 1.3 connector on the rear panel of the event controller. 

 On the event controller area of the front panel, press  to switch 
between Multiviewer image and image from the media server. Each time you 
press it, the image displayed on the smart touchscreen display screen changes 
from MVR1 to MVR2 and then HDMI 1.3 (control interface of the media server). 

8.3.12 Number Buttons 

The U5 Pro is equipped with number buttons, which are used to enter numbers when 
adjusting layer size, position, etc. 
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 Number buttons 

 

  to : Press to enter the corresponding number. 

 : Press to subtract 1 from the current number for fine adjustment. 

 : Press to add 1 to the current number for fine adjustment. 

 : Press to enter the decimal point. 

 : Press to delete a number or character to the left of the cursor. 

 : Confirm and exit the current input. 

8.3.13 Switching and Control Area 

 Switching and control area 

 

 FRZ: Freeze all the images of the selected screen. 

 FTB: Make the output images displayed on the selected screens fade to black. 

 LOCK T-BAR: Lock the T-Bar. After it is lock, pushing T-Bar does not take effect. 

 SWAP: Press the button to enable or disable the SWAP function. 



Event Presentation Switching Solution User Manual 8 U5/U5 Pro Event Controllers 

 

www.pixelhue.com 162 
 

 SWAP enabled: The button is solid green and the switching mode from PVW to 
PGM is swapping. That is, the PVW and PGM images are swapped during image 
switching. 

 SWAP disabled: The button is off and the switching mode from PVW to PGM is 
copying. That is, PGM copies the PVW image during image switching. 

 TIME: Set the transition effect duration. 

 Trans: Set the transition effect during switching. 
Currently only the Fade effect is supported. 

 CUT: Press to send PVW to PGM directly without transition effect. 

 TAKE: Press to send PVW to PGM with a selected transition effect. 

8.3.14 MIDI Module Area 

The MIDI module has 4 encoders and 8 faders, which can be used for property 
adjustment or MIDI keyboard control. 

 When used as a property adjustment, they can adjust the layer size, position, 
image quality, etc. 

 To use them used as a MIDI keyboard, connect the USB (MIDI/KVM) connector 
of the event controller to the controlled device, such as an audio console, a 
lighting console, etc. 

After the property adjustment information is bound to the encoders and faders, the 
corresponding encoder or fader icons will be displayed on the property adjustment 
page. 

 Bound to encoders 

 

When you enter a property area, the adjustment parameters are automatically bound 
to the encoders and faders, and the binding relation icons are displayed under the 
menu in the property area. The corresponding relation between the icons and MIDI 
buttons is shown in the figure below. 

When you rotate an encoder or a fader, the system automatically adjusts the 
parameters corresponding to the encoder or fader. If a property parameter does not 
have a corresponding encoder or fader, rotating the encoder or pushing the fader 
does not take effect. 

 Turn the encoder right to increase the corresponding parameter value, and turn 
the encoder left to decrease the value. 
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 Push the fader up to increase the corresponding parameter value, and pull the 
fader up down to decrease the value. 

 Binding relationship between menu adjustment and MIDI buttons 

 

8.3.15 Power Button 

 Press the  button in the upper right corner of the panel, and the system will 
automatically start up. After startup, the main touchscreen displays the home 
screen. 

 Power off the event controller through the following methods: 

− Press the  button in the upper right corner of the panel, select OK in the 
pop-up dialog box on the main touchscreen, and the system will shut down. 

− During the startup process, hold down the  button to force shutdown. 

8.3.16 T-Bar 

Pushing the T-Bar up or pulling it down to manually control the switching from PVW 
to PGM. The LED indicator shows the switching progress. 

During the process of pushing or pulling the T-Bar, pressing the buttons on the front 
panel of the event controller does not take effect. 
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 T-Bar area 

 

8.3.17 Keyboard 

The U5 Pro has a built-in 61-key mechanical keyboard. To open the keyboard, just pull 
the middle section on the front panel. 

 

8.3.18 Drawers 

The U5 Pro is equipped with two drawers for you to put some wires or small objects. 
To open the drawers, just pull the two sections next to the keyboard out on the front 
panel. 
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A Specifications  

A.1 P10/P20 Specifications 

 P20 P10 

Inputs 
8x DP 1.2/HDMI 2.0 

4x 12G-SDI 

4x DP 1.2/HDMI 2.0 

2x 12G-SDI 

Outputs 8x HDMI 2.0 
2x HDMI 2.0 

6x HDMI 1.3 

OPT Ports 8 4 

AUX Connectors 4x HDMI 1.3 2x HDMI 1.3 

3.5 mm Audio Jacks 
(October, 2023) 

2x Line in & 2x Line out 2x Line in & 2x Line out 

Layers 
3x 4K@60Hz layers + 4x 
2K@60Hz layers, or 4x 
4K@60Hz layers 

2x 4K@60Hz layers + 4x 2K@60Hz layers, 
or 3x 4K@60Hz layers 

Multiviewer Connectors 1x HDMI 1.3 1x HDMI 1.3 

Presets 128 128 

BKG & LOGO Up to 255 BKGs & LOGOs (Maximum storage space: 512 MB) 

Front Screen 5" LCD 5" LCD 

Gigabit Ethernet Ports 2 2 

Control  Front panel buttons and LCD 
 Event Controller U5/U5 Pro 
 Event Management Software PixelFlow 

Processing  FPGA-based high-performance image enhancement architecture  
 Real 4K60p 4:4:4 10-bit internal video processing 

Chassis  3 RU 2 RU 

Dimensions L 482.6 × P 501.0 × H 139.0 mm 

W 19.0 × D 19.7 × H 5.5 inches 

L 482.6 × P 493.0 × H 94.6 mm 

W 19.0 × D 19.4 × H 3.7 inches 
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 P20 P10 

Weight  Net Weight 10.2 kg / 22.5 lbs 7.9 kg / 17.4 lbs 

With Paper Box 14.3 kg / 31.5 lbs 10.2 kg / 22.5 lbs 

With Flight 
Case 

25.2 kg / 55.6 lbs 20.6 kg / 45.4 lbs 

Electric Parameters Input Power: 100-240V~, 3.0-
1.5A, 50/60Hz  

Max power consumption: 140 W 

Input Power: 100-240V~, 3.0-1.5A, 
50/60Hz  

Max power consumption: 82 W 

Noise on Average (@1, 
0.75m height) 

45.6 dB 41.9 dB 

Operating Environment 
Temperature: 0°C to 50°C (32°F to 122°F) 

Humidity: 0% RH to 80% RH, non-condensing 

Storage Environment 
Temperature: –20°C to +60°C (–4°F to 140°F) 

Humidity: 0% RH to 95% RH, non-condensing 

A.2 Q8 Specifications 

 Description 

Inputs Up to 48x 4K concurrent inputs through 6 input cards 

Outputs Up to16x 4K concurrent outputs through 4 output cards 

OPT Ports 8 

Layers 
32x 4K mixing layers in switcher mode 

64x 4K single layers in PGM only mode 

Multiviewer Connectors 2x HDMI 2.0 

Presets 1024 

BKG & LOGO Unlimited picture quantity in 1G storage space 

Front Screen 7" touchscreen 

Gigabit Ethernet Ports 2 

Control  Event Controller U5/U5 Pro 
 Event Management Software PixelFlow 
 Web GUI (Q3 of 2023) 

Processing FPGA based high performance image processing architecture with SuperView 
scaling engine inside 

Chassis  7 RU 

Dimensions L 482.6 mm × P 694.7 mm × H 335.3 mm 

W 19 × D 27.4 × H 13.2 inches 

Weight  Net Weight 141.7 kg / 91.9 lbs 

With Flight 87 kg / 191.8 lbs 
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Case 

Electric Parameters Power connector: 100‒240V~,6A,50/60Hz 

Max power consumption: 1400 W 

Noise on Average (@1, 
0.75m height) 

55 dB 

Operating Environment 
Temperature: 0°C to 50°C (32°F to 122°F) 

Humidity: 0% RH to 80% RH, non-condensing 

Storage Environment 
Temperature: –20°C to +60°C (–4°F to 140°F) 

Humidity: 0% RH to 95% RH, non-condensing 

A.3 U5/U5 Pro Specifications 

 U5 U5 Pro 

Front Screen 
Main touchscreen: 43.8" 

Smart touchscreen: 8" 

Main touchscreen: 21.5" 

Smart touchscreen: 8" 

Dimensions L 740 × P 492.67 × H 148 mm L 740 × P 492.67 × H 148 mm 

Weight  Net Weight TBD 46 kg 

With Flight 
Case 

TBD 60 kg  

Electric Parameters Power connector: 100-240V~, 
50/60Hz  

Max power consumption: 240 W 

Power connector: 100-240V~, 50/60Hz  

Max power consumption: 240 W 

Noise on Average (@1, 
0.75m height) 

Front: 45 dB Front: 45 d 

Operating Environment 
Temperature: 0°C to 45°C (32°F to 113°F) 

Humidity: 0% RH to 80% RH, non-condensing 

Storage Environment 
Temperature: –20°C to +60°C (–4°F to 140°F) 

Humidity: 0% RH to 95% RH, non-condensing 
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B Supported Resolutions 

B.1 P20/P10 

Input Bit Depth Sampling Supported Resolutions Supported Bandwidth 

DP 1.2 8bit RGB 4:4:4 

4096×2160@60Hz 
8192×1080@60Hz 

18 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 4096×2160@30Hz 
4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12bit RGB 4:4:4 4096×2160@30Hz 

4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

HDMI 2.0 8bit RGB 4:4:4 

4096×2160@60Hz 

8192×1080@60Hz 

18 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 4096×2160@30Hz 

4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12bit RGB 4:4:4 4096×2160@30Hz 

4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12G-SDI 8bit YCbCr 4:2:2 

4096×2160@60Hz 

11.88 Gbps 

10bit YCbCr 4:2:2 

12bit YCbCr 4:2:2 
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B.2 Q8 

Input Bit Depth Sampling Supported Resolutions Supported Bandwidth 

DP 1.2 8bit RGB 4:4:4 

8192×1080@60Hz 

4096×2160@30Hz 

3840×2160@60Hz 

21.6 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 

YCbCr 4:4:4 

YCbCr 4:2:2 

12bit RGB 4:4:4 

YCbCr 4:4:4 

YCbCr 4:2:2 

HDMI 2.0 8bit RGB 4:4:4 

4096×2160@60Hz 

8192×1080@60Hz 

18 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 4096×2160@30Hz 

4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12bit RGB 4:4:4 4096×2160@30Hz 

4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12G-SDI 8bit YCbCr 4:2:2 

4096×2160@60Hz 

11.88 Gbps 

10bit YCbCr 4:2:2 

12bit YCbCr 4:2:2 

B.3 U5/U5 Pro 

Input Bit Depth Sampling Supported Resolutions Supported Bandwidth 

HDMI 2.0 8bit RGB 4:4:4 

4096×2160@60Hz 
8192×1080@60Hz 

18 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 4096×2160@30Hz 
4096×1080@60Hz YCbCr 4:4:4 

YCbCr 4:2:2 4096×2160@60Hz 

12bit RGB 4:4:4 4096×2160@30Hz 
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Input Bit Depth Sampling Supported Resolutions Supported Bandwidth 

YCbCr 4:4:4 4096×1080@60Hz 

YCbCr 4:2:2 4096×2160@60Hz 

HDMI 1.3 8bit RGB 4:4:4 

2048×1152@60Hz 

4.95 Gbps 

YCbCr 4:4:4 

YCbCr 4:2:2 

10bit RGB 4:4:4 

YCbCr 4:4:4 

YCbCr 4:2:2 

12bit RGB 4:4:4 

YCbCr 4:4:4 

YCbCr 4:2:2 
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